Diablo® III

PS3 Multiplayer infinite loading problem

Hi, spoke with customer service representative Kvelorim, he said that he forwarded to the right channels for bug reporting, so it seems they are working on the patch now according to Kvelorim
Reply Quote
10/29/2013 09:33 AMPosted by Audial
The game should of said "Not compatible with Belkin routers" on the cover.

Asking any software company to code and account for broken/defective/faulty hardware is asking too much IMO.

Seeing that the game works with every other router under the sun so far to me seems like your frustration should be vented at Belkin and not Blizzard. In this case anyway.


I highly disagree with this. Belkin routers are not near as "broken/defective/faulty" as you may think they are. Just because it's not Netgear or Linksys doesn't mean the product they produce is crap. I've actively used a Belkin router for the past 6 years in my house with a large number of online capable games and never once had a problem. The game works for every other router brand, so why not Belkin? What's so different about a Belkin that causes it to act so much more diversely than the others? It's not too much to ask for a product to be fixed when it was previously working. You can't break something that previously worked and not expect the people who utilize it to not get immensely upset. The problem is with Blizzard and yes, we will vent our frustration at the ones who made the patch that messed it up. The patch wasn't written by Sony, nor was it a fault of Sony's at all. Blizzard made they game, they patch it, and they ruined it. End of story and the blame game.

And Thartux,
I highly doubt our concerns were submitted for debugging. It seems that's their only real reply to the issue and I'm 85% sure it won't be looked into. Given Blizzard's track record with fixing issues with their prize and crowning glory that was supposed to have been the PC version, they're going to give less of a crap about us console gamers. I'll be extremely surprised if they do, because so far their only one real solution is "Well screw you, go buy a router that isn't Belkin."
Reply Quote
11/01/2013 05:21 AMPosted by OiramX
I highly disagree with this. Belkin routers are not near as "broken/defective/faulty" as you may think they are.

I have nothing against Belkin and their products. Nothing negative to say. I was not attempting to infer that their products are inferior. All I was saying is that in this case the problem is only on Belkin routers. That coupled with the versions of the Belkin routers people are experiencing problems with have had a few updates specific to UPnP being broke which is where I think the problem lies.

Could Blizzard code around it? Possible, my company does frequently. But to blame Blizzard for this seems a little ridiculous, at least not until someone can definitively say that the code for Blizzard is what is causing this. If it were their code I would suspect the problem would happen on more than just Belkin routers. It is possible it is Blizzard though it is entirely more likely that this is Belkin simply because the models of routers have had a number of updates to fix issues with UPnP. If I had one of the routers I am sure I would be able to test and confirm this but alas, I don't.

I get that it didnt happen before the patch and it does now. That doesn't change that it is specific to Belkin routers. I am sure Blizzard coded their protocols to standard meaning if the Belkin product accepted the standard it would work. I could be wrong of course, though to me the likelyhood of it being Belkin is much higher than Blizzard.

11/01/2013 05:21 AMPosted by OiramX
Blizzard made they game, they patch it, and they ruined it. End of story and the blame game.

Fair enough statement. Asking for them to look at it to see whether the problem is Blizz or Belkin is quite different then simply blaming them for the fault. Anyone who has ever worked in DEV knows that the obvious solution, in this case your statement of Blizzard broke it after the patch, isn't always the proper solution. Technology is quite complicated what with all the protocols and standards used. I do computer work for fortune 100 companies, have even done some for Blizzard. There are always surprises and new things you learn no matter how positive you think you are of the answer. You absolutely have to keep an open mind and look at all possibilities rather than try to shoehorn your ideas of the problem into the situation.

In any case maybe Blizzard can spend $50 or so, buy a few of the Belkin routers, test them, and then come back and say "Woops, our bad. Here's a fix." or "Call Belkin.". If you need $50 let me know Blizzard, I'd be glad to spot you :D
Reply Quote
Alright guys, I found a solution. Well, it wasn't me who found it but I tested it and it works. Before I go on, I want to give all the credits to the original post which can be found in this thread on page 5. I didn't want to buy a new router or restore my system, so I tried the "Demo walk around". For those who don't know what this is, it's fairly simple.
1. You download the demo version of Diablo 3.
2. Start it up with a new character. (demo only have barbarian and wizard)
3. Enter the game in single player. (online not available on demo)
4. Play for like 1 minute.
5. Press the ps home button on the controller and go directly to the disc version of Diablo 3. (make sure the disc is already in the system before you start the demo)
6. Select the character you want to play and join a game.
7. The infinity loading screen shall now load up and you're free to play again.
Now here's the catch, if you turned off your ps3, you have to repeat steps 2-7 everytime. You don't have to start a new character in step 2 because you already have one. To sum this all up, yes it is the game and not the router. The router works fine after the "demo walk around". It can find games and join right up. Here's the real question: How come we need to do this "demo walk around" for it to work? I'm not an expert, so I'll let the experts at Blizzard figure this out.
Reply Quote
11/01/2013 09:35 AMPosted by AsianGuy
Alright guys, I found a solution.

This is absolutely screaming UPnP on the router is not functioning with Diablo 3. Not saying the router or Blizz is at fault, but I would be willing to bet my money that is where the problem is.
Reply Quote
I hope you're right Audial. Like I said, I'm not an expert but hopefully this helps Blizzard pinpoint the cause.
Reply Quote
Hi AsianGuy, yea I posted this workaround weeks ago, but it's a headache since you have to do this everytime you restart the PS3. I found out that you no longer have to stay in demo for a while, just load demo, in the avatar screen before you go into game you will see it connecting, once it says connected, just quit demo and go immediately to diablo disc version and it should work, something new I discovered. Less of a headache.

So I guess this wasn't happening before the latest patch? I never played before the patch since I just got the game about a month ago after this was already happening.

@OiramX
Yea, Blizzard probably won't address anything, I was just mad since that rep just assumed it would be sent for testing, console games is not their major concerns.
Edited by thartux#1653 on 11/3/2013 9:36 PM PST
Reply Quote
Tsarnis, thanks for replying to my previous posts. Maybe since the latest patch was the one that caused the problem making gamers have to use the demo for multiplayer to work, you can inform them that a new patch to correct the previous patch can be made? Thanks for any help. I know that in the support tickets, they just ignore what I say and say that if I wrote it here, they assume it will be already addressed. I am worried since many here say that Blizzard will not really put much effort into the console game and I also read online in google searches that the issue may never be addressed. I sure hope that isn't the case with Diablo3, which was a $59.00 dollar Blizzard game.
Edited by thartux#1653 on 11/3/2013 9:46 PM PST
Reply Quote
Thanks thartux. I'll try your quicker way of doing it. I bought this game the first day it came out because I was a D2 fan. Couldn't get it on pc because I got rid of my computer. When I heard it was coming out on PS3, I couldn't wait. Played great until the patch, too bad you bought yours right after the patch.
Reply Quote
You're welcome AsianGuy. oh ok, thanks for letting me know about the patch, so it's definitely the patch, I sure hope the tech support reads are posts here. Oh yea, DIablo 2 was awesome, got this game cause of the same reason as u, diablo 2 fan as well hehe. My favorite class was the necromancer, it's like a wizard and witch doctor all in one hehe.
Reply Quote
90 Night Elf Hunter
4360
Posts: 2,814
I'm having (I think) the same problem (PS3 version). Single player works fine, but when I try to go "online", it hangs up a bit (the lobby window's empty) and I get the message that goes something like: "Could not connect to server at this time. Please try again later."
Edited by Hebereke#1472 on 11/10/2013 8:42 PM PST
Reply Quote
Hi Celeano. This seems to be a problem with the latest Ps3 Patch affecting multiplayer gaming for those using a Belkin router or at least all those affected have a Belkin router.

A workaround that helps is: Download diablo 3 demo. Create a character. then load character. in the avatar screen it will say: "signed in" you do not need to enter a game, just from that point press the PS button and go to your full diablo game and multiplayer should work. Problem is that once you turn off your Ps3, you have to repeat this process.
Reply Quote
90 Night Elf Hunter
4360
Posts: 2,814
Thank you, kindly!
Reply Quote
Im having the same problem.
I've buyed game 3 days ago,was able 3 out 100 attempts to join in "open to public" network
Will try this thing with demo start.
Hope it works,and i more hope that Blizz make new patch with fix ASAP.
Reply Quote
Its not working for me,did everything like u said.
But still on singing in it says "not available atm try again later"...But the thing what i notice is that i can connect with every friend online.
But i just cant join random groups and "find game" tab is empty
Reply Quote
Hi DeVIa,

make sure in internet settings is set to: "friends only" then just to test this out, make a normal difficulty game, and choose "any act" just to see if the game isn't empty, and also make sure setting is to any region, no region bypass, etc, just try that and see if u can just connect to any public game.

I tried the Demo trick I described here because I couldn't join any game at all, not even a friend's game, so if you can at least connect to a friend's game and not public, maybe there is more hope for u, my guess, not sure, just try what I mentioned above and see if you have any luck.
Edited by thartux#1653 on 11/20/2013 6:08 PM PST
Reply Quote
Posts: 2
Alright, I've recently obtained the game on the PS3 to play with my g/f. As it turns out, she seems to have an issue to where she suffers from infinite loading and I cannot join her game.

I happened to be a PC/Network Tech. And have adjusted the settings, she is running a Belkin and connected the PS3 via wireless.

I have set up a static IP for her PS3 and have it under DMZ.
Furthermore, it is set to UPnP Enabled, with Media Connections Disabled. (Mind you, we have tried both to enable/disable/and even alternated.)

To this point, I'm convinced that this patch is indeed bugged and needs to be looked into unless someone can come up with a solution of some sort that I have yet to try.

We have exhausted all forms of options, done firmware update, connection tests, packet loss tests, etc. The PS3 runs beautifully in Castlevania Harmony of Despair (a Host based game), Mass Effect 3 (Host based game) and all of the Creed Games.

The Demo trick does NOT work with us here.

My system is running fine and I have it under DMZ as well, different houses. So yeah, again, why doesn't this game work here? DMZ is outside of the firewall/porting issues. So port Forwarding, tho enabled anyway for the fun of it, should not affect the DMZ affected PS3s.

Can someone assist or can a moderator please explain the situation?
Edited by Geo#1801 on 11/26/2013 5:58 PM PST
Reply Quote
Posts: 1
SOLUTION FOUND (no belkin)

This problem has been bothering my friend and I for the past weeks and I've been digging around the forum forever to find the answer. Here's my solution to the problem:

IF YOU ARE USING BELKIN => SWITCHED TO ANOTHER ONE

Sorry to disappoint but this has helped me despite my efforts in trying all the possible solutions (demo trick, opening up ports, NAT, firmware upgrade, etc.)

This has proven to work for me, I know some of you might think it's not worth buying another router just for D3 since belkin since to have worked for everything else. That's really up to you. Just wanted to share my finding.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]