Diablo® III

setup.app couldn't be opened in mavericks

Posts: 1
i'm using osx 10.9 mavericks with clean installation

and here's some problems below

starcraft 2 setup app >> works great, it can be opened, and the installation success
diablo 3 setup app >> couldn't be opened, after click it, but get no any response
beta system check app >> couldn't be opened, after click it, but get no any response
desktop app for battle.net >> diablo 3 installation hang in the begin
Reply Quote
MVP - Technical Support
Posts: 11,290
View profile
Have you tried repairing your permissions, to make sure there aren't issues in that area?

Resetting Permissions

1) Navigate to the folder containing your Diablo III folder, and then highlight your Diablo III folder in the Finder.

2) Right click the Diablo III folder icon and select Get Info.

3) Click the Padlock icon at the bottom of the Get Info window and enter your administrator password (this authenticates you as an administrator).

4) In the Sharing and Permissions tab, select the Everybody group and choose Read and Write option in the Privileges pulldown menu. Make sure you are working with the pulldown menu on the same line as the Everybody group.

5) Click the Cogwheel icon at the bottom of the window and select Apply to enclosed items. When it asks you to confirm this, select OK. Close the Get Info window.

Your permissions are now set properly for Diablo III and all of its game files.

6) Navigate to your /Users/Shared folder in the Finder.

7) Right click the Blizzard folder and select Get Info.

8) Repeat steps #3 through #5 for this folder, then close the window.

9) Right click the Battle.net folder and select Get Info.

10) Repeat steps #3 through #5 for this folder, then close the window.
________________________________________________
Technical Support MVP
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Reply Quote
Tried to launch setup.app after checking permissions and gatekeeper settings were in order, still nothing happens after opening it.
Reply Quote
Extracted app to Desktop.

Open terminal
cd ~/Desktop/Diablo\ III\ Setup.app/Contents/MacOS/
chmod +x Diablo\ III\ Setup
./Diablo\ III\ Setup

Works for me :)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]