Diablo® III

Severe fps drop on mouse hover

I find another thread with the exact same problem. http://us.battle.net/d3/en/forum/topic/5889789057
But that one is locked so I make a new thread.

1) Run around town keeping your cursor CLOSE to your character - game will be smooth. In my case, the average FPS is around 50.
2) While keeping in motion, allow the mouse to drift over something you can interact with - doesn't matter if it's the stash, blacksmith, NPC, item on the ground, portals and way points.
3) As long as the item is highlighted/hovered with mouse, FPS will drop drastically (to the neighborhood of <15)
4) As soon as the cursor is moved away from the item, FPS resumes normally

Operating System: Windows 8 64-bit (6.2, Build 9200) (9200.win8_gdr.130531-1504)
Language: English (Regional Setting: English)
System Manufacturer: Micro-Star International Co., Ltd.
System Model: GT60 2OC/2OD
BIOS: E16F4IMS.50H
Processor: Intel(R) Core(TM) i7-4930MX CPU @ 3.00GHz (8 CPUs), ~3.1GHz
Memory: 16384MB RAM
Available OS Memory: 16272MB RAM
Page File: 3668MB used, 18234MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11

the D3Prefs.txt
PreferencesVersion "44"
PlayedCutscene0 "1"
PlayedCutscene1 "0"
PlayedCutscene2 "20"
PlayedCutscene3 "0"
DisplayModeFlags "0"
DisplayModeWindowMode "0"
DisplayModeWinLeft "0"
DisplayModeWinTop "0"
DisplayModeWinWidth "1920"
DisplayModeWinHeight "1042"
DisplayModeUIOptWidth "2880"
DisplayModeUIOptHeight "1620"
DisplayModeWidth "2880"
DisplayModeHeight "1620"
DisplayModeRefreshRate "60"
DisplayModeBitDepth "32"
Gamma "1.000000"
MipOffset "0"
ShadowQuality "6"
PhysicsQuality "1"
ClutterQuality "3"
Vsync "1"
Letterbox "0"
Antialiasing "1"
LowFX "0"
LockCursorInFullscreenWindowed "0"
LimitForegroundFPS "0"
MaxForegroundFPS "60"
LimitBackgroundFPS "0"
MaxBackgroundFPS "10"
DisableTrilinearFiltering "0"
ColorCorrection "1"
MipBias "0.000000"
ReflectionQuality "0"
TonemapExposure "1.900000"
TonemapContrast "1.500000"
TonemapSaturation "1.000000"
TonemapGain "1.000000"
HardwareClass "4"
PCIVendor "32902"
PCIDevice "1046"
MasterVolume "1.000000"
EffectVolume "0.800000"
MusicVolume "0.800000"
NarrationVolume "0.800000"
AmbientVolume "0.800000"
ChannelsToUse "32"
SoundDriver "0"
SpeakerMode "0"
ReverseSpeakers "0"
QuestSubtitlesEnabled "1"
CinematicsSubtitlesEnabled "1"
MuteSound "0"
MuteEffects "0"
MuteAmbient "0"
MuteVoice "0"
MuteMusic "0"

Thank you.
Reply Quote
http://i43.tinypic.com/einv2s.jpg
http://i43.tinypic.com/104qouq.jpg
http://i40.tinypic.com/11c3wuh.jpg

I couldn't replicate the problem at all. My FPS is in the upper left.

DisplayModeUIOptWidth "2880"
DisplayModeUIOptHeight "1620"
DisplayModeWidth "2880"
DisplayModeHeight "1620"

^^^ might have something to do with the problem. Try displaying in 1920x1080.
Reply Quote
http://i43.tinypic.com/einv2s.jpg
http://i43.tinypic.com/104qouq.jpg
http://i40.tinypic.com/11c3wuh.jpg

I couldn't replicate the problem at all. My FPS is in the upper left.

DisplayModeUIOptWidth "2880"
DisplayModeUIOptHeight "1620"
DisplayModeWidth "2880"
DisplayModeHeight "1620"

^^^ might have something to do with the problem. Try displaying in 1920x1080.


Well, I tried to set the resolution in 1920x1080 but there was still a significant fps drop. It dropped from a steady 165 fps to around 60. So I think the resolution is not the problem here.
Reply Quote
http://i43.tinypic.com/einv2s.jpg
http://i43.tinypic.com/104qouq.jpg
http://i40.tinypic.com/11c3wuh.jpg

I couldn't replicate the problem at all. My FPS is in the upper left.

DisplayModeUIOptWidth "2880"
DisplayModeUIOptHeight "1620"
DisplayModeWidth "2880"
DisplayModeHeight "1620"

^^^ might have something to do with the problem. Try displaying in 1920x1080.


Well, I tried to set the resolution in 1920x1080 but there was still a significant fps drop. It dropped from a steady 165 fps to around 60. So I think the resolution is not the problem here.


Are you running in fullscreen mode?

I've never used an Intel HD GPU, is there a control panel that allows tuning per application?

If you're going from 100+FPS to exactly 60FPS it appears the game, or your GPU, is activating Vsync momentarily for some odd reason.
Reply Quote
[quote][quote]Are you running in fullscreen mode?

I've never used an Intel HD GPU, is there a control panel that allows tuning per application?

If you're going from 100+FPS to exactly 60FPS it appears the game, or your GPU, is activating Vsync momentarily for some odd reason.


Yeah, I am running in full screen. And I actually uses the discrete GPU, not the Intel GPU to run this game. I am pretty sure the 60 fps has nothing to do with the Vsync. It is probably just a coincidence. Anyway, the odd thing is that even the FPS is around 60, there is still an obvious pause and then lag when I move the mouse over any interactive object. As soon as I move away the mouse, everything becomes normal and smooth.
Reply Quote
What is your dedicated GPU? have you updated the drivers for it?
Reply Quote
11/19/2013 06:39 PMPosted by runit3
What is your dedicated GPU? have you updated the drivers for it?


GTX 780M. I have upgraded to the newest driver. But the problem remains.
Reply Quote
Some possible steps to try:

In the D3 video options disable all options (AA, Vsync, Frame lock). Choose whatever model quality you want, just make sure any other controls are completely off/unchecked. Close the game client, restart the client, and make sure the options are exactly as you set them previously. Close the game client.

Go into the Nvidia control panel, under 3D settings choose manage 3D settings, then choose the program settings tab.

Under select a program to customize, choose diablo iii.exe, if it is not there add it to the list by choosing the appropriate file path.

Under vertical sync choose "ON", power management mode "Prefer maximum performance", Antialiasing mode "override any application setting" (you can set the AA at whatever value you wish- although I would recommend no higher than x4 for a laptop card), Texture filtering - negative LOD bias to "Clamp", Texture filtering quality "High performance".

Restart the game and see if you can get the FPS drop again. If overriding all D3 controls hasn't worked you may need to roll back your Nvidia drivers until you find a working version. It's unlikely that this is a game related problem, but on the off chance it is I would delete the battle.net and Blizzard entertainment files within the program data cache. Directions here: https://us.battle.net/support/en/article/delete-the-battlenet-cache-folder
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]