Diablo® III

[BUG] Can't force VSync externally

If I enable VSync in-game I get stuttering, but if I disable it in-game and force it on via Nvidia Inspector it works great, the problem I'm having is this no longer works after the 2.01 patch, and it didn't work on the PTR either (I reported it then as well). I can force custom AA, AF and AO but VSync refuses to be forced on using Nvidia Inspector. Please pass this along so it can be fixed.

Update: You can't externally force VSync using any application, the game refuses to recognize the command. Nvidia Inspector, Nvidia Control Panel, ATI Control Panel and D3DOverider have all been tested. This is a major problem for people with 120/144Hz monitors as this was the only workaround for them, it also affects everyone else as the in-game VSync option causes stutter and general performance degradation.
Edited by MrH#2528 on 4/10/2014 10:24 PM PDT
Reply Quote
I'm trying to activate Nvidia Inspector's v-sync right now as I type this. I can confirm D3 broke this function. I hope other Inspector users post here to get Blizzard's attention.
Reply Quote
D3DOverrider isn't working either. I would always just use that pre patch to fix the weird stuttering issue from the vsync bug. Doesn't work anymore and it's giving me massive headaches trying to play.
Reply Quote
Posts: 5
I use Nvidia Control Panel to force "adaptive vsync" in all my games. Pre-patch 2.0.1 adaptive vsync worked great locking me in at 144 fps for my 144hz monitor in Diablo 3 and after downloading the new patch yesterday it does not work at all. I'm forced to use the in-game frame limiter which is very unstable....in-game vsync is also much worse.

It seems Diablo 3 has lost communication with Nvidia control panel regarding vsync capabilities. Hopefully this will be addressed soon.
Reply Quote
Same here, after new patch, in-game vsync works, but sucks royally. Constant frame hitches and overall worse performance. Used to be able to force it via control panel/inspector/d3doverrider etc, now that no longer works for whatever reason as stated...
Please fix this!
Reply Quote
I just tried this and found the same thing yall are describing. Vsync cannot be turned on through the hardware to use on the game.
Reply Quote
I contacted customer support but he didn't really seem to understand the issue. I also contacted Nevalistis on Twitter and apparently she passed it on to the devs, so we'll see if it gets fixed. I really hope it does because the in-game vSync causes so much stutter and hurts the performance a lot, whilst forcing it via Nvidia Inspector works perfectly.
Reply Quote
Yes, same issue here. Forcing vsync through the NVIDIA control panel or inspector worked fine pre-patch, post-patch it is no longer working.
Reply Quote
03/01/2014 06:41 AMPosted by MrH
I contacted customer support but he didn't really seem to understand the issue. I also contacted Nevalistis on Twitter and apparently she passed it on to the devs, so we'll see if it gets fixed. I really hope it does because the in-game vSync causes so much stutter and hurts the performance a lot, whilst forcing it via Nvidia Inspector works perfectly.


tbh, using any of the in-game options like anti-aliasing, vsync, etc are worse then using the ones in your hardware drivers since the ones in the video card control panel are made for your card. so realistically all options on the card should take priority over the in-game options.
Reply Quote
Same here, but with AMD drivers, forcing Vsync through AMD Catalyst is not working anymore for Diablo 3.
Reply Quote
03/01/2014 02:14 PMPosted by Morogoth
03/01/2014 06:41 AMPosted by MrH
I contacted customer support but he didn't really seem to understand the issue. I also contacted Nevalistis on Twitter and apparently she passed it on to the devs, so we'll see if it gets fixed. I really hope it does because the in-game vSync causes so much stutter and hurts the performance a lot, whilst forcing it via Nvidia Inspector works perfectly.


tbh, using any of the in-game options like anti-aliasing, vsync, etc are worse then using the ones in your hardware drivers since the ones in the video card control panel are made for your card. so realistically all options on the card should take priority over the in-game options.


Agreed. I force CSAA and disable it in-game, which still works. I actually reported this issue during testing as it affected the PTR client as well, but I guess no one important reads the bug forum. I'm hoping they fix this issue ASAP because the stuttering is driving me crazy, but it's still preferable to screen tearing.
Reply Quote
03/02/2014 12:44 AMPosted by MrH
03/01/2014 02:14 PMPosted by Morogoth
...

tbh, using any of the in-game options like anti-aliasing, vsync, etc are worse then using the ones in your hardware drivers since the ones in the video card control panel are made for your card. so realistically all options on the card should take priority over the in-game options.


Agreed. I force CSAA and disable it in-game, which still works. I actually reported this issue during testing as it affected the PTR client as well, but I guess no one important reads the bug forum. I'm hoping they fix this issue ASAP because the stuttering is driving me crazy, but it's still preferable to screen tearing.


Yeah the tearing in this game without vsync is just crazy :(
Reply Quote
03/02/2014 05:43 AMPosted by tRevz
...

Agreed. I force CSAA and disable it in-game, which still works. I actually reported this issue during testing as it affected the PTR client as well, but I guess no one important reads the bug forum. I'm hoping they fix this issue ASAP because the stuttering is driving me crazy, but it's still preferable to screen tearing.


Yeah the tearing in this game without vsync is just crazy :(


Indeed, so until they fix externally forcing vSync we have to choose between stuttering or extreme tearing.
Reply Quote
I can confirm this problem too. I have a 144hz Monitor, forced with nvidia control panel,adaptive v-sync(or normal vsync) is not working at all.Cant get 144fps limit. With ingame V-sync i can get 60fps but i get tearing.

Please fix this. It´s driving me crazy!
Edited by Gromkash#2171 on 3/3/2014 1:12 PM PST
Reply Quote
Fix plz..
Reply Quote
03/03/2014 01:39 PMPosted by Cheezus
Fix plz..


That would be nice, but I'd like to point out that I reported this bug on the PTR forum in January so they've known about it for a very long time and have done nothing to correct it.

http://us.battle.net/d3/en/forum/topic/11422882775
Reply Quote
03/03/2014 01:10 PMPosted by Gromkash
I can confirm this problem too. I have a 144hz Monitor, forced with nvidia control panel,adaptive v-sync(or normal vsync) is not working at all.Cant get 144fps limit. With ingame V-sync i can get 60fps but i get tearing.

Please fix this. It´s driving me crazy!


If you're running 144hz the in game vsync should put you at that fps if your computer can handle it.. unless of course it's locked at 60 for whatever strange reason Oo
Otherwise maybe try the max fps slider to 144fps?
Edited by tRevz#2384 on 3/4/2014 3:41 AM PST
Reply Quote
Ingame V-Sync never worked with 144hz, had to force it with Nvidia Control Panel and adaptive V-Sync. But now this doesnt work anymore since 2.0.1. With V-Sync disabled my computer is running over 300 fps so 144fps are not a problem to achieve. But its not working
Edited by Gromkash#2171 on 3/4/2014 5:40 AM PST
Reply Quote
Here's hoping the patch around the corner will address this? Why wouldn't Blizzard fix a hardware problem and why don't we have a blue post at the very least?
Reply Quote
Yep patch didn't do anything about hardware v-sync. Thanks Blizz?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]