Diablo® III

[BUG] Can't force VSync externally

03/04/2014 04:16 PMPosted by SpaceFolding
Yep patch didn't do anything about hardware v-sync. Thanks Blizz?


That's bad to hear, I was hoping our issue got stealth fixed.
Reply Quote
I'm having the same problem. I just can't force adaptive vsync outside the game anymore.

They need to fix this asap.
Reply Quote
same problem here
Reply Quote
New patch broke a lot of things, couldn't even select my Nvidia chip anymore until someone posted a fix here, it was stuck on integrated graphics.
Reply Quote
I had the same vsync related stuttering. Increasing pre-rendered frames to 4 solved the problem.
Reply Quote
and how you do that?
Reply Quote
03/06/2014 12:05 PMPosted by Artemis
I had the same vsync related stuttering. Increasing pre-rendered frames to 4 solved the problem.


Will this introduce any input lag side effects in this game?
Reply Quote
pre-rendered frames is set in the nvidia control panel under "3d settings'. Select diablo III.exe from the list of games and it's in the settings for that.

I don't know if it will create input lag. Probably not on 460 GTX cards and above.
Reply Quote
It would be nice if a blue could at least let us know if the devs are working on a fix for this bug?
Reply Quote
I can confirm that adaptive v-sync does not work. I can't stand tearing, and normal v-sync causes stutter. Fix this, please. Thanks!
Reply Quote
03/08/2014 04:42 AMPosted by Mirage
I can confirm that adaptive v-sync does not work. I can't stand tearing, and normal v-sync causes stutter. Fix this, please. Thanks!


As it stands now you have to pick which you hate the least, tearing or stutter, which isn't an ideal situation.
Reply Quote
Can a blue please confirm this is on the "to fix" list? It really sucks to be ignored like this.
Reply Quote
Display issues like this are usually solved by amd or nvidia. I would guess we will see updated drivers that fix these issues by March 25.
Reply Quote
Bump, same problem here. I posted another thread with not much action. There's a new nvidia driver out today, but problem still exists.
Reply Quote
Any blues have any feedback?
Reply Quote
03/06/2014 12:05 PMPosted by Artemis
I had the same vsync related stuttering. Increasing pre-rendered frames to 4 solved the problem.


I will say this helped a little.

Hopefully Blizzard will fix (or at least acknowledge) this bug soon.
Reply Quote
Still broken in today's patch.
Reply Quote
There is one other known issue that nvidia apparently fixed when they released 300.xx.

Set 'Power Management Mode' to 'Full Performance'. This will run the video card at full power, even if you're just idling in town. It uses more power and generates more heat/noise but it fixes this same stuttering problem.

Like I said, nvidia fixed this some time ago but it's possible it came back. Doesn't hurt to try.
Edited by Artemis#1554 on 3/11/2014 8:19 PM PDT
Reply Quote
03/11/2014 08:18 PMPosted by Artemis
Set 'Power Management Mode' to 'Full Performance'.


I already have this setting on Full Performance globally for many years and it doesn't really affect D3's v-sync frame drop. I shouldn't even call it a frame drop because the in-game fps counter will always report 60 fps. What's happening is the game likes to occasionally halve the refresh rate. You can set maximum pre-rendered frames to 8 as a brute force method for now. Doing this requires some extra work from the GPU.
Reply Quote
Are you guys forcing triple buffering or is that still opengl only option?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]