Diablo® III

[BUG] Can't force VSync externally

Bump, can't we get something from a blue?
Reply Quote
I had stuttering before patch 2.0.1, now, with in game vsync, I don't have any stuttering. Currently on i3 2100, 8gb ram, geforce 650Ti boost. This thread actually surprised me with the title (I thought why was this an issue at all, you have in game v-sync...) oh well...
Reply Quote
03/20/2014 10:47 PMPosted by TosterNS
I had stuttering before patch 2.0.1, now, with in game vsync, I don't have any stuttering. Currently on i3 2100, 8gb ram, geforce 650Ti boost. This thread actually surprised me with the title (I thought why was this an issue at all, you have in game v-sync...) oh well...


It's mainly an issue for people with 120/144hz monitors.

Still no blue update.
Reply Quote
Put be down for another 120hz constant stutter. I have to run in full screen windowed mode to get the adaptive sync from nvidia control panel to register, but then D3 doesn't run nearly as stable in windowed mode. I don't know why the nvidia settings don't take in full screen. I have never had this problem with any other game and the built in vsync in D3 is horrible. I never drop below 120 fps yet there is constant tearing in the center of the screen.
Reply Quote
03/24/2014 06:24 PMPosted by gutterboy44
Put be down for another 120hz constant stutter. I have to run in full screen windowed mode to get the adaptive sync from nvidia control panel to register, but then D3 doesn't run nearly as stable in windowed mode. I don't know why the nvidia settings don't take in full screen. I have never had this problem with any other game and the built in vsync in D3 is horrible. I never drop below 120 fps yet there is constant tearing in the center of the screen.


It was working perfectly until patch 2.01 which is when they broke it.

If you are affected by this bug try sending this Tweet out:

@CM_Nevalistis Please pass on this thread to the devs, we are being ignored on the forum: http://us.battle.net/d3/en/forum/topic/11883508489?page=1

(copy+paste into Twitter)
Edited by MrH#2528 on 3/25/2014 8:57 PM PDT
Reply Quote
I have a 60hz 24" Dell IPS panel, and a 560ti 2gig Twin Frozr and seem to be having this weird issue also. Could this be the reason?

My issue isn't a drop in FPS because it always stays at 60. It seems to be some kind of loading or slowdown, I'm really not sure what it is. Even when I lowered all my graphics down I still had the same issue.

Is this the same problem you guys are having? Thanks for the help.
Reply Quote
I would really like to have an answer about this, come on blue!
Reply Quote
Adding my name to the list of users who would like a resolution to this. Honestly, I was surprised to not only find that this was actually a problem with the game and not my hardware, but to find a post about it as recent as this.

I'm hoping this helps my problem. Two gtx 760s oughta be able to maintain 60 but I still drop to 45 occasionally and it bothers me. :(
Edited by Ripture#1612 on 3/26/2014 7:07 PM PDT
Reply Quote
Bump
Reply Quote
I'm keen to see a fix for this also, in-game Vsync is only 60fps on my 120hz screen.

Was using D3DOverider with in-game disabled but that's broken now.
Reply Quote
I just bought Diablo III yesterday, since I didn't know about this issue.

I can't play the game, since the level of stuttering without vsync gives me a headache in about five minutes and I can't force nvidia's working vsync.
Edited by FancyRaptor#1151 on 3/27/2014 12:31 PM PDT
Reply Quote
Update: If you have an AMD card I've found RadeonPro does work to force vsync. I need to run the game then ALT+TAB back to desktop and back to the game.
Reply Quote
Same issue here.
Please, some feedback would be appreciated...
Reply Quote
Forcing Vsync in RadeonPro actually got rid of my microstutter while 60FPS issue completely for me... nice
Reply Quote
Still not fixed for Nvidia cards. Cmon Blizz.
Reply Quote
Bump...
Reply Quote
I'm getting tired of this.
Reply Quote
Still having this problem with a real good computer.. geforce 780gtx i7 etc.. SSD harddrive. BUT still just having 60 fps with v-sync on, even my screen can handle 144hz...

Something is really wrong here: P

I tried almost everything.. My friend have 120fps with a worse computer then me! So is it wrong with nividia cards only?

I think a mod should answer asap
Edited by Partybeast92#2563 on 4/1/2014 7:34 AM PDT
Reply Quote
The problem is that they don't seem to understand that a LOT of people can't play the game properly without external V-sync (because in-game one is crap) so I doubt they're paying enough attention to this at all.
Reply Quote
Having the same problem. I have a screen that supports 75hz, and I'd like to play at that refresh, but the lack of external vsync makes that unbearable. Please fix it!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]