Diablo® III

Stuck using integrated graphics. ><

(Sticky)

So, this is happening.

http://imgur.com/82Rt0jq

I have a Geforce GT 750M in my laptop, and I'm using the newest 334.89 driver version. For every single other program on that list, I can select the nvidia GPU. For D3, I'm stuck on integrated graphics, and the selector is grayed out. Doesn't matter if the global setting is set for nvidia. D3 still will only use the crappy integrated GPU.

Why? What do?
Reply Quote
Figured it out. Gonna share my solution, in case anyone else is having a similar problem.

In the nvidia control panel, select the "Desktop" menu at the very top and make sure that "Add 'Run with graphics processor' to Context Menu" is checked.

Find the game folder and make a desktop shortcut for "Diablo III.exe" (NOT the launcher). Right click on the shortcut, and in the target field, you should see something like:

"C:\game folder\Diablo III.exe"

Append a -launch operator at the end of this line. It should now read:

"C:\game folder\Diablo III.exe" -launch

To play the game with your nvidia GPU instead of crappy Intel HD, right click on that shortcut, select the "Run with graphics processor ->" menu, and select "High-performance NVIDIA processor."

So much better!
Reply Quote
im having thsi problem too

your fix worked however i cannot use the bnet app anymore with it being broken like this

would like a blue response cuz i liked the bnet app
Reply Quote
same problem, after patching, the frame from more than 100 to now less than 20
Reply Quote
03/06/2014 09:08 AMPosted by Darthshatner
Figured it out. Gonna share my solution, in case anyone else is having a similar problem.

In the nvidia control panel, select the "Desktop" menu at the very top and make sure that "Add 'Run with graphics processor' to Context Menu" is checked.

Find the game folder and make a desktop shortcut for "Diablo III.exe" (NOT the launcher). Right click on the shortcut, and in the target field, you should see something like:

"C:\game folder\Diablo III.exe"

Append a -launch operator at the end of this line. It should now read:

"C:\game folder\Diablo III.exe" -launch

To play the game with your nvidia GPU instead of crappy Intel HD, right click on that shortcut, select the "Run with graphics processor ->" menu, and select "High-performance NVIDIA processor."

So much better!


This works, thank you!

03/06/2014 09:52 AMPosted by Tigz
im having thsi problem too

your fix worked however i cannot use the bnet app anymore with it being broken like this

would like a blue response cuz i liked the bnet app


this would be like a temporary fix, hope everyone with the same problem comes and check this out, so there is a blue post on the future regarding this.
Reply Quote
Thanks for sharing, had the same issue on EU servers but due to Blizzard Tech Support i got here and it works for me!

Cheers!
Reply Quote
03/06/2014 09:08 AMPosted by Darthshatner
Figured it out. Gonna share my solution, in case anyone else is having a similar problem.

In the nvidia control panel, select the "Desktop" menu at the very top and make sure that "Add 'Run with graphics processor' to Context Menu" is checked.

Find the game folder and make a desktop shortcut for "Diablo III.exe" (NOT the launcher). Right click on the shortcut, and in the target field, you should see something like:

"C:\game folder\Diablo III.exe"

Append a -launch operator at the end of this line. It should now read:

"C:\game folder\Diablo III.exe" -launch

To play the game with your nvidia GPU instead of crappy Intel HD, right click on that shortcut, select the "Run with graphics processor ->" menu, and select "High-performance NVIDIA processor."

So much better!


Thanks a lot, it works
Reply Quote
Works, thank you.
Reply Quote
This just started happening to me as well, even though it worked just fine earlier this day.
Reply Quote
If only i had seen this thread before i decided to reinstall. Thought it was my installation. I seek comfort that so many have fixed what seems to be the same problem i have.

EDIT: Worked perfectly, thanks man!
Edited by Svenno#2194 on 3/6/2014 1:07 PM PST
Reply Quote
03/06/2014 10:10 AMPosted by Cosmoflips
This just started happening to me as well, even though it worked just fine earlier this day.


New patch created this issue.
Reply Quote
I was having this issue as well, and this helped TONS. I hope this remains a temporal fix and Blizzard fixes it ASAP 'cause I like the b.net launcher.
Reply Quote
Same problem, solution worked. Thanks!

EDIT: @Omrakos: yes, this is thankfully possible, otherwise the game would currently be unplayable.
Edited by Kräuterorc#2990 on 3/6/2014 12:35 PM PST
Reply Quote
When i try that solution it says that i don't have the privileges to choose the preferred graphic card from that menu...
Reply Quote
Just overclocked the GPU in my laptop, ran it fine for few hours, then next start, I get this. I was nervous as !@#$. Thanks for the info!
Reply Quote
Support Forum Agent
Kräuterorc,

I see that. I'm letting our QA guys know now. This workaround seems like it will work in the meantime.

Update - 5/29/2014

For anyone still experiencing this issue, we'd like to have you try something to see if it resolves it.

In your Desktop App, without any games running, click on the blue icon in the top left to access the Battle.net menu. Click Settings, then Game Settings. Enable the box for Additional command line arguments below the Diablo III: Reaper of Souls entry. Enter the following: -usepageflip and click the Done button below on the right.

Try the game again and see if the issue remains.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Edited by Omrakos on 5/29/2014 2:16 PM PDT
Reply Quote
@Omrakos It does NOT work for me. It still opens the bnet app.

Anyidea?
Reply Quote
Support Forum Agent
PeuPicaseca,

I would have to guess you haven't created the shortcut properly.

Can you cut and paste what you have on the Target line please?

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
@Omrakos
"C:\Program Files (x86)\Diablo III\Diablo III.exe" - launch

EDIT

now it works, it seems that i`ve put a space before "launch" sorry for the inconvenience!
Edited by PeuPicaseca#1239 on 3/6/2014 1:18 PM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]