Diablo® III

Very long loading time?

Added on top of the other problems with crashing, when I enter a game, enter a town portal, teleport with way point, exit game etc etc, everything takes very long time! We are talking about 30-45sec per loadscreen almost every time!

So imagine killing diablo for example, enter game 30sec, enter townportal 20-30sec, kill diablo, tp to town 20-30sec, exit game and join a new game 1min+++

Is this only me?
Reply Quote
Same thing happening to me, and on top of that I can't even join or start any games. haven't been able to really play for a few days now
Reply Quote
Same for me. It never used to take this long and I'm using the same computer I used to pre-patch 2.0, so I wouldn't think it was due to my computer's specs. I also noticed that when entering from one area to the next, without teleporting using someone's flag or a waypoint, just walking from lets say keep depths 2 to keep depths 3, that it takes a very short amount of time like it should. It only happens when entering/exiting game and entering/exiting town.
Reply Quote
Same for me, but only since yesterday, was fine before. Those very long load times just appeared out of nowhere, plus they came with occasional lag spikes. Same PC as always with plenty of power to run D3 with a stable and quite fast internet connection.
Reply Quote
Exact same issues here. Have given the gentleman over in tech a system profiler which it doesnt seem they are equipped to read, they suggested that the "Optimal system requirements" listed on the box I purchased the game in as well as the website were outdated and I should increase my RAM from 4 gigs to 8 gigs or more. I'm going to spend the 100 dollars on the RAM upgrade and I will be SHOCKED if it is effective. 1 min+++ of load time to run has prevented me from playing this game at the same level as my PC using compatriots and of course none of them want to party with a guy who takes longer to get into/out of a game then some common runs take to complete. The most annoying part of this is probably the corporate line that there must be some issue on our end of things. Game loaded fine 3 weeks ago, I didn't change a thing, YOU DID, game is now broken, must be my specs? The incredibly slow loading times were present and obvious in the PTR, as were the consistent crashes, you released a broken game that is more broken for one segment of your community then another, compensate that segment.
Reply Quote
I would love to know that you(bliz) have at least read my post, this becomes a social problem where I understand if people don't want to play with me. I didn't buy this game to play single player. And I don't appreciate spending hours on this game farming different routes, when I know that I could've done 10-40% more runs if only this game worked as good as it does on PC.
Edited by lmfao#1189 on 3/10/2014 6:11 AM PDT
Reply Quote
Same thing happening on my imac, very slow loading times randomly.
Reply Quote
Same here..worked perfect before patch......now I can't play with my friends because of the long loading times.

So many issues beside the long loading times: crashing, flickering and freeZing.
Reply Quote
Bump for unfixed post patch
Reply Quote
Double bump. Patch 2.0.3 didn't do diddly squat to fix any of the problems we're facing. Load times are still insane and the game is still crashing.
Reply Quote
Bump, it kept telling me to update my OS so I did... load times still long since patches.
Reply Quote
Same
Reply Quote
Bumping because my friend is having the same issue on his Macbook.
Entering the game, using waypoints, TPs -- significantly slow loading times. However, using a doorway to go from level to level in a dungeon works fine.
Reply Quote
yup another "same" here
Reply Quote
03/13/2014 07:40 AMPosted by labrat1317
yup another "same" here


and another.

Mac client got trolled hard by this new patch
Reply Quote
I'm having this same problem, and now seemingly a related new one. When I try to start a game with one of my heroes, there is the usual long load time (that happens during any transition in the game) but now since patch 2.0.3 more often than not I get a disconnected from server message before the game even loads.

Mac mini 2011
Mavericks OS
Reply Quote
MVP - Technical Support
View profile
The long load times are not a mac only problem. there are blue posts about it on the main forums. They are working on that, if it's not already solved yet.
Reply Quote
Two of my friends who I play with very often, has either minimal loading time, like 4 seconds and the other one has 4-10. Barely any when they enter town portal. Haven't heard the latter guy complain anything recently so maybe PC users loading time has been fixed.
It's just not the same when I enter. They can clear out the first group of mobs before I arrive. Sometimes halfway done on second. That is just not OK.
Reply Quote
03/15/2014 05:29 AMPosted by lmfao
It's just not the same when I enter. They can clear out the first group of mobs before I arrive. Sometimes halfway done on second. That is just not OK.


Same here
Reply Quote
Same.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]