Diablo® III

Entire RoS Unplayable; Act V NOT Optimized

OS 10.9.2
Processor: 2.26 GHz Intel Core 2 Duo
Memory: 4GB 1067 MHz DDR3

I run the entire game smoothly on all low settings, i can go higher if i want with different things but i dont care to so i always run on low. After playing RoS i've found that all of Act V is one big lag fest. It's so bad the game wont recognize my mouse clicks, inputs, and movements for about 1-2 seconds after they are inputted. This makes the game virtually unplayable (try dodging Uzrael on a 3 second delay).

Has anyone else been having this issue with ONLY Act v?
Edited by GoldenHawk#1372 on 4/15/2014 5:56 PM PDT
Reply Quote
I'm having this issue as well... I didn't think to go back to play previously Act to see if it was happening then, but this past weekend I was playing the other acts just fine with no problems. My latency is fine, but my FPS jumps all over the damn place. It goes from like 30 to 4 then to 15 then down again and rarely makes it back up. Reminds me of what Vanilla was like back in the day.

I'm currently attempting to re-install both D3 and RoS.

Processor 2.4GHz Intel Core 2 Suo
Memory 4 GB 1067 MHz DDR3
Graphics NVIDIA GeFore 9400M 256 MB
OS X 10.9.2
Reply Quote
Got the same machine spec as Strat and I got the same problem. 2 weeks ago, I start playing again and was happily surprised to see there was no lag. Then yesterday came and it feel like it starting all over again.

On the bright side ROS seem like what Diablo 3 needed. Please let me know if re-install fix it.
Reply Quote
on my Macbook air 2013 its ROS unplayable, full Diablo 3 i have medium settings without problems (30 fps and 70-80C CPU temp) but in ROS act 5 i have 100C on low settgins and macbook automaticly lowing CPU clock and game is freezing...

only ACT 5 :-( i don't play on macbook now, ACT 5 is unplayable :-(
Edited by sallvator#2362 on 3/26/2014 1:12 PM PDT
Reply Quote
Did full re-install, still unplayable.

The only parts of Act V that are playable are the smallest environments like Malthael. Town, Pandemonium Fortress etc... are completely unplayable.

How could they release a game not optimized to fit seamlessly with system requirements from the previous game to this one?

As it stands now i will not ever be playing Act V again until a fix is provided. We are playing on perfectl adequate machines it makes no sense the game cant run properly
Reply Quote
I hadn't tried to play the previous acts and as it turns out this issue is still happening... I've un-installed and re-installed and it did nothing... It was fine a few weeks ago so I have no idea what's wrong now... So infuriating...
Reply Quote
MVP - Technical Support
View profile
Act 5 seems to have a ton of performance bad spots, even on high end systems and even on windows. Hopefully they can address these issues

There are other bugs too that cause slow downs. Friends or clan members earning achievements cause FPS spikes

Opening bag in combat can cause a short freeze. Etc.
Reply Quote
I am experiencing issues when I portal from inside an instance in Act 5.

My game critically crashes and closes.
Reply Quote
I had to turn down my resolution one notch for act 5.

It was definitely noticeable and still is, compared with my experience pre RoS launch.
Reply Quote
So I started playing a Crusader and it was going great... Now it's happening everywhere. Though in the earlier acts I get bursts of high FPS which are followed by low FPS again.
Reply Quote
I'm having the same issue on a Macbook Pro Retina.

Acts I-IV are fine, no slow down, lag or anything but Act V is very patchy in places. The worst are seems to be Westmarch, especially when it's on fire. It could be that the smoke effects are what's really killing performance.
Reply Quote
MVP - Technical Support
View profile
03/27/2014 01:33 PMPosted by Strat
So I started playing a Crusader and it was going great... Now it's happening everywhere. Though in the earlier acts I get bursts of high FPS which are followed by low FPS again.

Probably a little off topic from the act 5 specific slow downs.

On the note of act 5 slow downs, I hope you are reading these threads too S4d1k and can give insight into the slow downs. Worst spot for sure is the burning town area in act 5. Not sure if it's the fire or the smoke. But this brings even my system down to 20fps and I have a beasty hackintosh (which you technically don't support but it basically means my machine is stronger than ANY mac out there and to go to 20fps on an overclocked haswell cpu at 4.3ghz and an overclocked nvidia 780 desktop gpu on a 16x PCI express 3 bus with 32 gigs of ram is pretty awful. Whatever the bottleneck is, it's not processing power or memory/bus bandwidth.
Reply Quote
Not too much, but yes there is a little lag in act 5 especially with fire in the street.
Reply Quote
Act V is essentially unplayably slow for me as well. I have to just slowly click my way to following people as they clear the way. If i were to guess it is around half a FPS.

NOTE TO BLIZZARD EMPLOYEES:
I don't know if this helps you guys understand the issue a little better, but this is exactly the same problem I had with my mac in the Dahlgur Oasis in the D3 launch week or month. It was eventually fixed but the problem is exactly the same.
Reply Quote
In some sense I'm happy to see that I'm not alone suffering this issue, because this probably means that it is only a matter of time until bliz solves it.
Big levels in Act V are not playable (response time is about 0.5 seconds).
The worst zones are the Town and Pandemonium Fortress lvl 1. Also I believe all Westmarch is slightly choppy. I'm used to subpar performance in my late 2009 mac but these parts are unplayable.
Acts 1 to 4 are still fine.

Point is: playing Act V is not fun except for the smaller/simpler areas
Reply Quote
im having the same issue.......from act 1-4 smooth playing but when i play on act 5 it goes terrible i can't play the quests....
Reply Quote
Same exact specs as the OP:

OS X 10.9.2
2.8 GHz intel core 2 duo
4 GB 1067 MHz DDR3
NVIDIA GeForce 9600M GT 512 MB

Same exact problem. The game runs fine at times (40-50 FPS) but maybe 60% of the time I have severe severe lag that makes it nearly unplayable. I did not have the issue at all when I was playing on the PTR before ROS was released. What's the problem??
Reply Quote
In some sense I'm happy to see that I'm not alone suffering this issue, because this probably means that it is only a matter of time until bliz solves it.
Big levels in Act V are not playable (response time is about 0.5 seconds).
The worst zones are the Town and Pandemonium Fortress lvl 1. Also I believe all Westmarch is slightly choppy. I'm used to subpar performance in my late 2009 mac but these parts are unplayable.
Acts 1 to 4 are still fine.

Point is: playing Act V is not fun except for the smaller/simpler areas


Same deal here. Although I don't have as many problems in regular mode, but the performance problems are still there. Most of my substantial issues are in ACT V adventure mode rifts. The game will crash EVERY-SINGLE-TIME when teleporting to either an ACT V town or from an Act V rift level. This is 100% repeatable.

This doesn't occur when im in an Act I-IV rift level and try to teleport to a Act I-IV town.

I think ACT V is pretty terribly optimized and the extra haziness and shadows from the rifts just push the client over the edge.

If you are a diablo player and find that you are blowing keys in the rift things due to these crashes, it is a lot easier to avoid the crashes if you start in an ACT I town and push the rift levels after beating the guardian until you are teleporting from an Act I-IV zone.

Processor: 3.06GHZ Intel Core 2 Duo
Memory: 4GB
NVIDIA GeForce 8800 GS 512 MB
Software OS X 10.9.2
Reply Quote
act 5 is playable for me...except for the cimetery place that has the same graphical bug (white flickering) as act 1 highlands and fields of misery zones.
Reply Quote
Same issues here. Act 1-4 run at a smooth 45-60 FPS but act 5 is pretty rough with an FPS range of 25-45 in the open areas. The last section of act 5 is especially bad with an average FPS of 30.

Playing with high settings with the exception of having shaders off and no vsync or fx.

I'm playing on a 21.5 inch IMAC with the 650M Nvidia card.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]