Diablo® III

Cannot connect to Battle.net at all

Not sure if this is related to the other issues or not; if so, I apologize for making a new thread. I just didn't want to mine into another thread if it turned out to be a different issue.

So this is not a disconnect thing, this is a can't connect thing. I played for a few hours earlier today, everything was fine. Went away, came back, tried to play again. First thing I notice is the Battle.net launcher has the big Disconnected icon at the top right, with the "Go Online" button lit up. I try clicking it, it thinks thinks thinks, nothing happens.

So I try launching the game and logging into D3 proper. I get to the "Establishing Connection to Battle.net", and it just sits there. I let it go for about five minutes, no error messages, nothing, just doesn't move. Exited out after that.

Other threads were asking for traceroutes - no idea if that's relevant to my issue or not, but I did it anyway, just to be safe.


Tracing route to 12.129.209.68 over a maximum of 30 hops

1 8 ms 21 ms 15 ms 192.168.224.1
2 2 ms 2 ms 2 ms cust-etsu-70-1.mounet.com [216.145.70.1]
3 2 ms 2 ms 1 ms 10.0.1.1
4 1 ms 2 ms 2 ms 10.219.80.17
5 2 ms 2 ms 2 ms 172.26.194.10
6 * * * Request timed out.
7 5 ms 4 ms 5 ms 172.26.97.1
8 5 ms 319 ms 4 ms dnat136.nettn.org [70.150.247.136]
9 5 ms 4 ms 5 ms dnat136.nettn.org [70.150.247.136]
10 10 ms 10 ms 10 ms 12.94.104.53
11 60 ms 59 ms 62 ms cr1.attga.ip.att.net [12.122.117.26]
12 63 ms 60 ms 60 ms cr2.dlstx.ip.att.net [12.122.28.174]
13 60 ms 59 ms 60 ms cr2.la2ca.ip.att.net [12.122.28.178]
14 111 ms 147 ms 59 ms gar29.la2ca.ip.att.net [12.122.129.241]
15 59 ms 59 ms 59 ms 12.122.251.190
16 59 ms 59 ms 61 ms mdf001c7613r0002.lax1.attens.net [206.16.68.54]
17 61 ms 60 ms 59 ms 12.129.209.68

Trace complete.


I'm in Tennessee, which isn't really Northeast, but I don't know how this series of tubes called The Internet works, so for all I know it may be related to that. I dunno.

So, yeah. Not sure if it's related to the other issues or not. I leave that in your capable hands, Blizz Tech Support. :)
Reply Quote
I'm having the EXACT same problem. can't connect to the B-net launcher, never connects on the d3 login screen, no errors.

I ALSO live in NE Tennessee.
Reply Quote
Potatoehead - do you have a Steam account? I find I'm unable to connect to mine right now, wonder if it's something similar going on.

I can still connect to Origin, for what that's worth.
Reply Quote
Well, now both Battle.net and Steam are working.

Alright then.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]