Diablo® III

Why doesn't the screenshot page work right?

Posts: 266
This page is not loading all of the images and the original image links do not work.

http://us.battle.net/d3/en/media/screenshots/
Community Manager
Posts: 3,659
The site just went up late last night so there's still a few bugs to iron out.

But you can help us! Head to the Website Bug Report forum and let us know if you're seeing any issues or errors. Before doing that be sure to check the Known Issues Sticky, and actually this specific issue is already listed there. :)

http://us.battle.net/d3/en/forum/topic/3074647569
Edited by Bashiok on 8/24/2011 10:07 AM PDT
Posts: 475
I'm having the same issue. Only the first 5 images work for me.
100 Blood Elf Paladin
13365
Posts: 331
The site just wen live some time ago, let them fix it.

Indeed, the Website Report Forum is a good place to report such things. =)
Posts: 15
The site just went up late last night so there's still a few bugs to iron out.

But you can help us! Head to the Website Bug Report forum and let us know if you're seeing any issues or errors. Before doing that be sure to check the Known Issues Sticky, and actually this specific issue is already listed there. :)

<a href="http://us.battle.net/d3/en/forum/topic/3074647569">http://us.battle.net/d3/en/forum/topic/3074647569</a>


I would like to thank you for putting the site up at all! Bugs or no, we have been eagerly waiting for any morsels to chew on. This site is starting to become filling! :3
Posts: 266
The site just went up late last night so there's still a few bugs to iron out.

But you can help us! Head to the Website Bug Report forum and let us know if you're seeing any issues or errors. Before doing that be sure to check the Known Issues Sticky, and actually this specific issue is already listed there. :)

<a href="http://us.battle.net/d3/en/forum/topic/3074647569">http://us.battle.net/d3/en/forum/topic/3074647569</a>


Ah good call, I should have checked the Bug section. Thanks for the quick response!
85 Goblin Shaman
3365
Posts: 10
Some links still revert back to the old "Community Website" and then wont allow access back to this site, also from the actual "Battlenet" account screen when clicking on the Diablo3 page link and then "Community Website" it still links to the old and not this one.

I am sure you are already aware of this at this point but just letting it be known :]
Posts: 20
Hot damn I love Bash, I missed you man.

And here's my two cents: sometimes when clicking the numers of the posts to quote them doesn't work for me :(
Edited by Kain on 8/24/2011 2:09 PM PDT
Posts: 4,098
Does anyone like my comment on the screenshot of the Monk at the Door? Or pretty bad?
Posts: 55
Working pretty well from my view , looks beautiful actually.......ahh it's so nice to be a blizzard fanboy.
Posts: 15
Most glaring issue is the noticeable lack of a personalized greeting welcoming me to the beta. :)
Posts: 433
Oh good Bashiok your avatar no longer had ADD...
Posts: 348
08/24/2011 04:26 PMPosted by Clobbit
Most glaring issue is the noticeable lack of a personalized greeting welcoming me to the beta. :)
I second that, hahaha. But hey, lets see what Blizzard has to say by Sep 30th.
This topic has reached its post limit. You may no longer post or reply to posts for this topic.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]