Diablo® III

BETA FPS & Lag issue?

85 Draenei Shaman
9055
Posts: 57
During my experience I have noticed frame lag when discovering new environment (virtually all the time) or when there is a dense group of mobs on my screen and I am going for a lot of kills at once etc..

I don't doubt my system as much as I do some sort of bad or inefficient coding on the part of this BETA. I have searched for other threads on this and need more clarification perhaps. Are we just supposed to be satisfied with the experience even if it is incredibly difficult to play at times when frames are lost? My computer is fairly new and runs everything else beautifully.

Here are my specs. Anyone else experience this? Is it not 2012? Why not a more fluid frame experience D:

MY SYSTEM SPECIFICATIONS

OPERATING SYSTEM:
Windows 2.6.1.7601 (Service Pack 1)
CPU TYPE:
Intel® Core™ i5 CPU 750 @ 2.67GHz
CPU SPEED:
2.68 GHz
SYSTEM MEMORY:
2 GB
VIDEO CARD MODEL:
NVIDIA GeForce GTS 250
VIDEO CARD MEMORY:
1.73 GB
VIDEO CARD DRIVER:
nvd3dum.dll
DESKTOP RESOLUTION:
1920x1080
HARD DISK SIZE:
931.41 GB
Reply Quote
This is most likely just internet lag causing this, the MOP Beta is on the same servers, and has been casuing some issues with the D3 Beta, they know about this and are working to rectify the situation. (server side game, lag will cause a drop in FPS)

I was running 60fps solid last night, it seems like its coinciding with MOP invites. (they keep adding more Annual Pass holders every day)
Edited by D3BETA on 4/5/2012 10:42 AM PDT
Reply Quote
Posts: 390
Been like this since forever,... Seems the engine doesn't load assets till experienced but Tristram has a !@#$ ton of first time assets..they reload EVERY launch of the client, not just one...seems to be cpu intensive not gpu and is really annoying... I hope it goes away by launch date.
Reply Quote
i think you are short of system memory Oo

2gb is very low nowdays you should get atleast 6gb
Reply Quote
Posts: 390
i think you are short of system memory Oo

2gb is very low nowdays you should get atleast 6gb
. I have 12 and I still experience it
Reply Quote
well 2 still too low imo
Reply Quote
I've noticed this too. I'm running a amd II athlon x4 630 @ 2.8 ghz and a gtx 560 ti superclocked gpu. When I monitor my gpu during gameplay the temps barely rise, it never uses more than 50% of my gpu processor and it is consistently @ 60fps after the game has been running for at least 5 minutes. However when monitoring my cpu the first 5 minutes of gameplay make it spike to nearly 100% usage causing MASSIVE fps drops(down to nearly 10 fps) and whenever I enter a new zone or there are mass amaounts of mobs and 4 other players, my cpu ramps back up to 100% usage and down goes my fps again. (no i do not have any virus or spyware, just did a clean wipe and fresh install of windows 7 two days ago to see if it would help the lag and fps drop)

Edit- I also have 6 gigs of ram
Edited by D3BETA on 4/5/2012 10:51 AM PDT
Reply Quote
04/05/2012 10:50 AMPosted by D3BETA
I've noticed this too. I'm running a amd II athlon x4 630 @ 2.8 ghz and a gtx 560 ti superclocked gpu. When I monitor my gpu during gameplay the temps barely rise, it never uses more than 50% of my gpu processor and it is consistently @ 60fps after the game has been running for at least 5 minutes. However when monitoring my cpu the first 5 minutes of gameplay make it spike to nearly 100% usage causing MASSIVE fps drops(down to nearly 10 fps) and whenever I enter a new zone or there are mass amaounts of mobs and 4 other players, my cpu ramps back up to 100% usage and down goes my fps again. (no i do not have any virus or spyware, just did a clean wipe and fresh install of windows 7 two days ago to see if it would help the lag and fps drop)


That is..........

Thats really strange.

My CPU never breaks 40% at any time in D3, I do get a little bit of stutter when I first load up the game, but its minor (like 5fps drops here and there), and it dissapears after 1 minute, like clockwork. Heck, my GPU never breaks 85% usage ever either..... (all settings maxxed, forced MLAA, forced 16 x AF)
Edited by D3BETA on 4/5/2012 10:53 AM PDT
Reply Quote
If D3 and MoP are being tested on the same servers then we ought to hear a lot of complaints from them about their frames experience. It is a shame that quality of performance is being compromised >.<
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]