Diablo® III

Server performance

25 Troll Hunter
0
Posts: 204
Hey Oceanians. Everyone who's in the beta, please post here your general whereabouts, what your pings are, and the resultant lag effects, just so we can all get a general idea of what we're up against. Cheers!
Reply Quote
Tasmania, Australia.

I won't be buying the game, because even playing single player I'm experiencing terrible rubber banding and crippling combat lag.

Approx. 200ms ping.
Reply Quote
Posts: 26
I'm from Melbourne, with Optus.

Games runs sweet for me. 190ms to 220ms ping, Only had it spike to 340 once in 5 hours of play.

I don't feel a delay at all.
Reply Quote
mine running smooth as silk, on an imac i5 27" and it is awesome, i am truly blown away by the game, the only thing i think it needs is , dare i say, AH and in game chat like wow,i wont be buying another game unless its an expansion :)
Reply Quote
25 Troll Hunter
0
Posts: 204
What pings are you getting, and whereabouts are you playing from, balam?
Edited by Ferastin on 4/16/2012 10:21 PM PDT
Reply Quote
I'm in Wellington, NZ, on Xnet.

Latency usually around 200ms +/- a bit, feels good, I don't feel a lag.
Only had a major lag spike once, shortly after a maintenance, guess the server was a bit overloaded, locked up as I ran into a mob of monsters; was dead when the action returned after 20 secs. :p
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]