Diablo® III

More Lag Recently?

90 Tauren Paladin
8205
Posts: 139
I havent had an issue previously with D3 - like it seemed to play as per a normal game on my computer, but the last few days , its become unplayable in single player mode. I notice my ping is hovering between 400 -> 450 but its soo hard to play as its just not responsive and there are delays and its soo frustrating that i just cant play it.

Has anyone else noticed a change regarding this? I've made sure my wireless is disabled (to make sure no ones syphoning my net) and also ensured i'm not downloading anything but the ping is still around the 400->450.

I'm going to be annoyed if i have to subscribe to wow tunnels to get D3 playable :)
Reply Quote
Where are you?
I'm in auckland, NZ and I've only seen my ms increase by 20 (from 180). And thats not all the time, and not even during the open beta (which was last weekend in case that's why it was worse for you).

EDIT: wow tunnels is so damn cheap its almost worth it anyway imo.
Edited by Psyklone#1140 on 4/24/2012 6:58 PM PDT
Reply Quote
What do you mean recently?

Its, always been there!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]