Diablo® III

ATI 12.4 Catalyst – Graphic Issues *Update*

kind of strange, here is my issue with my HD 3650; I'm getting those gray/green backgrounds while loading the game..

http://i.imgur.com/9mH5p.jpg (windowed 1280x760)
http://imgur.com/Nxv6O (full screen 800x600)

anybody else with this gray-green like background issue?

(I have updated all the required drivers..)

edit 1: I had the same problem within the open beta, I downgraded to oldest drivers, same things, now, it's clear there is something going on with the HD 3xxx, 4xxx, AMD chipset/driver/hardware regarding D3...
Edited by braincras#1481 on 5/15/2012 7:28 PM PDT
Reply Quote
85 Worgen Warrior
7900
Guys, I had the same problem as you in the past 24 hours. ATI 12.4a hotfix initially did not work(grey screen and stuff). But then I've uninstaled all video card drivers and catalyst control center. EVERYTHING! Then I've just installed ATI 12.4a hotfix from here http://support.amd.com/us/kbarticles/Pages/AMDCatalyst124ahotfix.aspx and it works like a charm:)

Hope this will help! Have fun guys!


So I'm trying this out at Windows 7 but when uninstalling AMD products, the "Windows Installer stops" and all I can do is "close the aplication", wich makes the uninstalling process continue, but I can't trust it'll work.

Someone tried that and had this problem?

Update: Done. Uninstalled all Video Drivers (and Catalyst Center), restarted the computer, cleaned the reg (with CCleaner) and instaled the 12.4a hotfix. Now I'm waiting D3 comes back from maintenance to see if it worked.

Update 2: It's working! I have a Radeon 3400 Series and after doing all this stuff it's working fine. A bit slow, bu no bugs!
Edited by Dunncan#1790 on 5/15/2012 11:44 PM PDT
Reply Quote
I have an ATI RADEON 3200 HD on my laptop, and I'm having terrible graphic issues. What should I do?
Reply Quote
90 Human Warlock
0
05/07/2012 03:58 PMPosted by Bashiok
Users of the ATI Radeon HD 2400, 2600, 2900, 3400, 3600 and 4500 graphics cards are the only AMD customers who need to download this hotfix driver.


This hotfix did not work for my ATI Mobility Radeon HD 3400 graphics card -- if anything, it made things worse. The background is grey & distorted, even the text smudges on the screen.
Reply Quote
i also had this in beta and retail but i found a solution
your going to want to remove everything go to control panel, uninstall programs double click ati install thing click next then select the 3rd option to remove all amd software once thats done dont restart go to your device manager and under display adapters open up your video card and uninstall that too now restart your comp and it will reinstall your video card then just download 12.4a hotfix and it should work like it worked for me and some others
Reply Quote
I can confirm that the ATI Radeon HD 4300 series also is affected by this problem under Win 7.
Reply Quote
I have and HD 3870 x2 and i have this problem too. The hotfix didnt do nothing.
Btw i have windows 7 64bits. Its sad :S
Reply Quote
Same problem here (HD 3400 series). I tried all in my position, hotfix didn't do anything, I also tried all types of compatibility mode, Windows 7 basic mode (sometimes it helps).
Bad and huge Problem. The best way with our graphics cards is in windowed mode, nothing changes but at least you can see your character.

:(

Windows 7 Pro x64
DirectX 11
ATI Mobility Radeon HD3450

I'm here, waiting/looking for a solution.
Reply Quote
I have and HD 3870 x2 and i have this problem too. The hotfix didnt do nothing.
Btw i have windows 7 64bits. Its sad :S


exact the same setup here.
Having Problems with graphics too.

All "light sources" are terribly pixelated!
Reply Quote
ok guys here's how i did it, I got ATI 3870 on win 7 64bit:

1) uninstalled ati from control panel
2) didnt reboot
3) went to device manager and right clicked on ati -> unistall and checked box remove driver also
4) didnt reboot when asked
5) clicked on scan for hardware changes
6) didnt reboot
7) windows autoinstalled the gpu and it this driver worked, although it was too slow
8) tried catalyst 12.4a didnt work
9) uninstalled 12.4a
10) tried catalyst 12.4 didnt work
11) uninstalled 12.4
12) tried catalyst 12.3 and works fine!!!!111oneone
13) at last... fml!
Reply Quote
I have a HD 6970 lightning edition and I get game freezes left and right. It d/c me so its unplayable on my custom built rig. Running CCC 12.3 as I thought it would fix it but nope. Sad that I have to play on my laptop with a 460M graphics card in it to play D3.

I cant wait for the GTX 690 to be available long enough for me to buy. I think Im done with ATI and their drivers.

CPU:FX-8150 3.6ghz
Board:Crosshair V Formula
Cooling: Corsair H70
RAM: G.Skill Jigsaw 8gb 1600
SSD: OCZ Vertex 3 120gb (Boot drive)
GFX: MSI HD 6970 Lightning Edition
PSU: Thermaltake RX2 1000W

Here is rig if anyone has any suggestions on fixing freezes until 690
Reply Quote
ok guys here's how i did it, I got ATI 3870 on win 7 64bit:

1) uninstalled ati from control panel
2) didnt reboot
3) went to device manager and right clicked on ati -> unistall and checked box remove driver also
4) didnt reboot when asked
5) clicked on scan for hardware changes
6) didnt reboot
7) windows autoinstalled the gpu and it this driver worked, although it was too slow
8) tried catalyst 12.4a didnt work
9) uninstalled 12.4a
10) tried catalyst 12.4 didnt work
11) uninstalled 12.4
12) tried catalyst 12.3 and works fine!!!!111oneone
13) at last... fml!


Thanks I'll give it a try. I hope it works or else I am going to jump ship and buy an nvidia card.
Reply Quote
85 Undead Priest
10320
I'm using the Mobility Radeon HD 3650

Tried 12.3 Doesn't work
Tried 12.4 Doesn't work
Tried 12.4a hotfix... guess what? Doesn't work. This is stupid beyond reason.

even tried the mobility mod. failed.

Half the mobs in game are missing and every light source is just a beacon of pixels.

edit: and now World of Warcraft is getting artifacts. smh.
Edited by LordDRC#1917 on 5/16/2012 4:28 PM PDT
Reply Quote
85 Tauren Druid
6660
12.4a made things MUCH worse
Reply Quote
running 6850, after update to 12.4, i cant even launch game without locking everything up. Battlefield 3, skyrim and SC2 all lock up. Time to roll back.

** 2 friends also having same issue :( figured id post it.
Edited by Wororm#1683 on 5/16/2012 10:45 PM PDT
Reply Quote
everytime i dl a new update for catalyst, its always buggy as hell. good thing i stayed at 12.3
Reply Quote
This hotfix doesn't work for the mobility series of cards
Using a Mobility HD3670
Reply Quote
ok guys here's how i did it, I got ATI 3870 on win 7 64bit:

3) went to device manager and right clicked on ati -> unistall and checked box remove driver also [edit: I REBOOTED]
12) tried catalyst 12.3 and works fine!!!!111oneone
13) at last... fml!


These are the steps I did... and it worked.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]