Diablo® III

Updating System Files.

90 Blood Elf Priest
8865
Posts: 13
ya im at the installer now and downloading the game, currently at 17% and it looks like its going well. I hope when it gets to 100% ill be able to play, but for WoW i cant use the launcher it wont open the .exe for me i have to go to the folder and actually open the .exe. ill give that a try when its finished downloading and hopefully it works
Reply Quote
85 Orc Warrior
5430
Posts: 65
Crap job with the installer Blizzard..
Reply Quote
Did all this and its now stuck on 0% staying there for like 5-6mins... need to prolly update Win7 files again. Brb after this. Hope it works!
Reply Quote
The "most awesome launch night ever" has quickly turned into "the worst possible launch night of any game ever" with this. At least on other launch nights, I could install the damn installer.
Edited by Knarral#1776 on 5/15/2012 2:20 AM PDT
Reply Quote
85 Orc Warrior
5430
Posts: 65
The "most awesome launch night ever" has quickly turned into "the worst possible launch night of any game ever" with this. At least on other launch nights, I could install the damn installer

Same, at least I could get the game installed. Now it's this "Updating Game Files / Launching..." bs.
Reply Quote
That works thanks alot :D
Reply Quote
Posts: 27
I'm having the same problem too. I was able to get to the installation screen two month ago and when I clicked install I would get the message that says the game hasn't launched yet.

And just today, I encountered the same situation as I read through all posts:

downloader getting stuck at 1/3
deleting files in ProgramData
secondary logon
sutting down Agent in task manager
"Updating data files..." goes up to 2/3, 95%, then back down to 2/3 and stops
getting critical error on Agent
pulling my hair out
wiping tears

Still looking for blue help.

God help us all.
Reply Quote
The quickest way for Blizzard to fix this would be to discontinue using the new battle.net agent and go back to 'tried and true' methods.
Reply Quote
Yeah now installed new SP1 for WIN7 and BAM. Back to the old fn problem with agent.exe collapsing, while everything toward beta files / programdata is deleted. Everything gone, reboots done nothing helps.

GREAT!
Reply Quote
90 Blood Elf Priest
8865
Posts: 13
what i found worked for me with the "Updating setup files..." issue was i downloaded the battle.net folders from

http://www.gamefront.com/files/21699449/D3+-+Battle.net+Files.zip

because im running windows XP 64 bit edition, i went to C:\>Documents and Settings>All Users>Application Data and i replace the battle.net folder in there with the downloaded one, ALSO in the Application Data folder, there is a Blizzard Entertainment folder, i had to replace the Battle.net folder inside both the Application data folder, and the Blizzard Entertainment folder. after that i just ran the Diablo-III-Setup-enUS and it got past the "Updating setup files..." issue very quickly.

Just downloading the game now and good to go :D

Hopefully this helps!
Edited by HaviK#1460 on 5/15/2012 2:47 AM PDT
Reply Quote
Ok guys. Now I am first time on the road to actually install this damn game.

Done parts:

Deleted all the progra shiet which explained before

regedit.exe -> killed all agent.exe things and all battle.net roots

-> killed agent.exe from system manager. Now everything is clean -> hit install from .exe.

Now going 15% !!!
Reply Quote
Posts: 171
Here's some steps I found from a user on the MOP Beta forum. It's worth a try as they have the same issue with Agent.

STEP 1: open your internet explorer and do the following:

internet options > Connections > LAN Settings > uncheck "Automatically detect settings"

STEP 2: CTRL ALT DEL Kill any Agent*32/Launcher.exe

go to : C:\ProgramData\ and delete the Battle.net folder (THE WHOLE FOLDER)

Run the installer now. When it seems to hang:

Start Task Manager and end the Agent.exe process (not process tree). Then take a look at your updater. It should complete.

____________________________________________________________________
Support Information Administrator


I tried this and it hasn't helped. Thankyou for the work you are putting in but seriously who created this crappy installer
Edited by mansfield#1147 on 5/15/2012 2:49 AM PDT
Reply Quote
90 Blood Elf Priest
8865
Posts: 13
I feel so stupid because im a WoW anual pass holder, so i had a free d3 to begin with, but at midnight when the game droped i went and bought a retail copy in hopes that it would fix that problem >< what a terrible 67$ mistake that was but really we shouldnt have had any issues to begin with, they held the game off for so long they could have held it off a little more to make the installer work properly
Reply Quote
Hi all,

I resolved this issue by doing the following

- start secondary logon service and set to automatic
- delete battle.net folder in the program data folder
- run launcher as admin
>>> At this point the 'updating setup files' froze at about 95% <<<
- let it sit there for a couple mins and then opened task manager and killed the Agent process, did not kill the D3 setup process
- The agent service did not restart as it normally would, i went to C:\ProgramData\Battle.net\Agent\Agent.954 and ran agent.exe as admin
>>> The progress bar then went back to halfway, and then started processing all the way to 100%<<<

i am now installing the game.
Reply Quote
Okay, I think I just got lucky. It finally installed for me, and now I'm busy installing the game from the launcher.

Yeah, I had to wait for about 30 minutes for it to finish from the last agent reset (where I essentially just ended the Agent 32 process) for it to install, but I doubt it was patience that prevailed rather than just the combination of everything I have done tonight.

All in all -
about 15 battle.net deletes
about 4646546546 agent resets
about 27 restarted updaters
half way in compatibility mode: XP SP3 and half in compatibility mode Windows 7
987654321654 frustrated posts

Note: none of these are hyperbole. I actually took the time to count everything. And if you believe that, I'm also a billionaire who will buy Activision, fire Bobby Koteck, punch Mr. Morheim (in the face with that dwarven accent), and install 2345628374562093475290375243908572390487 more D3 servers. And if you still believe all of that, then the only thing I require from you is all of your collective firstborns.
Reply Quote
my bet is blizz has done this deliberately to delay everyone playing at the same time
and then when the updater works theyll come up with some lame excuse
Reply Quote
92 Blood Elf Hunter
4050
Posts: 3
Ok so I checked the Secondary logon, it was set to manual already, but I switched it to Auto to see if that worked. No dice. Now i'm trying to delete the Battle.net folder, and my computer is telling me that the action cannot be completed because a file in it is open in another program, but I don't have anything open aside from iTunes and this webpage... Any other thoughts?

EDIT: Ok, so downloaded file posted in thread as it seemed to work for so many people. Ensured my Blizzard folder was deleted and Cache folder. Ran as admin, got to 1/3 as per usual. Task Manager > Ended agent.exe file and launcher continued up to about 95% then changed from "Updating Setup Files" to "Loading Blizzard Launcher". Yay! But no... agent.exe reappeared and launcher went back to "Updating Setup Files" and 2/3 progress bar and stuck... Don't know what else to do. :/
Edited by Rhukia#1495 on 5/15/2012 5:16 AM PDT
Reply Quote
85 Worgen Warrior
4265
Posts: 2
My updating setup files box is stuck at half and iv tryed everything you have posted . I cant find
C:\ProgramData\Battle.net folder next. Pluse i havent had any Battle.net games on here
Reply Quote
85 Night Elf Mage
7835
Posts: 47
My Fix as follows.

Downloaded the battle net files linked in the thread
Put them in the corresponding folder.

No agent.exe running.
Using the CD from the store (bought gf a copy...so i could use the CD).
ran regedit.exe

-searched the registry for agent.exe, found the first one and deleted it that was actually linked to the bnet folder, don't remember the location, went through a few more and deleted a second which was in the firewall rules section, probably didn't need to delete that.

ran the client setup in the battlenet folders downloaded, got the installer instantly (run as admin) however couldn't install as decompression error occurred (due to no downloaded files no doubt).

So i then closed everything, and ran the setup from the CD (which is in a folder on the PC, no cd drive so copied it through lan to mine from gf's pc) no iso etc, just folder with contents dumped in it.

Win 7 x64.
windows firewall off
selective startup.

Secondary login i changed awhile back to allow desktop to use it or something, tickbox in config somewhere, also changed it so that on 3rd fail it would just try to run it again instead of stopping the service. (no idea if that is relevant, as it was the bnet files that seemed to really change anything for me).

Done all from a tethered Iphone, so wasn't able to test safe mode stuff.

Hope this helps somewhat.

using the new nvidia 680Gtx, standard drivers from release date.
that's about all i can think of that's relevant, cheers.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]