Diablo® III

Updating System Files.

FOLLOW THIS EXACTLY TO FIX THE SETUP FILES NOT UPDATING, THIS IS A NEW METHOD TO FIX IT. (Tested on Windows 7)

I think I found a solution that should work for everyone. This is exactly what I did and it'll pull you through the updating setup files problem of installing Diablo 3.

1. Make sure agent.exe isn't running in task manager.
2. Delete your C:/ProgramData/Battle.net Folder
3. Right click your Diablo 3 Installer.exe thingy, Set the compatibility to Windows XP (Service Pack 3).
4. Now right click your Diablo 3 Installer.exe and click "Run as Administrator"
5. Now wait, it should freeze at 90% after a minute or 2.
6. Once it's stuck at 90%, go to your C:/ProgramData/Battle.net Folder, then go into your agent folder, and then into the Agent.954 folder.
7. In here, right click Agent.exe and click "Run as Administrator"
8. Now wait and it will finish updating the setup files.

Also just a side note, some people get stuck at 0% while installing the game after making it past the "Updating Setup Files" bug. Here's how you fix this bug, then you're home free.

1. End agent.exe processes (all of them)
2. "X" out of the installer
3. Now go back to Agent.954 folder and right click Agent.exe, run it as administrator
4. Now go back to your Diablo 3 Installer.exe thingy, right click it, run as administrator.
5. Click install and wait, it will sit at 0% for a bit
6. Then it should start installing and you'll finally be done with the bull crap.

Hope this helps <3


I have literally been playing around with this all !@#$ing day and THIS is the only post in this forum that has worked for me. I urge anyone who is frustrated beyond belief to try this!
Reply Quote
100 Night Elf Hunter
11530
Posts: 3
Thank you so much I was so mas I was about to kill someone
you just saved a innocent man's soul gratz
Reply Quote
Posts: 273
Legit's files worked for me.

Thank you. I will see you on the fields of battle, where I will accidently mistake you for a demon at first, then kick you across a mountain.

As the flamingo class.
Reply Quote
Posts: 3
this worked for me go to computer>local disk>Programdata and delete the Battle.net file, it was that simple. Took me forever to figure it out thoughonce you delete the battle.net file just run the diablo 3 setup installer program thing and it should work, just give it a few minutes
Reply Quote
Posts: 4
Nothing is working. I've deleted the battle.net folder and the cache, I've downloaded the files manually, I've run things as admin, I've run in selective boot mode, I've messed with all the agent files...nothing.

If I delete the battle.net folder, then run the setup, it fills up about 5%, then resets itself. Then it fills up to about 30%, runs all 3 different agent files, then gives me the error.

If I run it when there are files in the battle.net folder it never gets past 0%.

Any other ideas?
Reply Quote
I got to the Launcher...
Was Stuck at "Launching Blizzard Launcher"
I have tried every option I've found on this issue and some other fixes that slightly resemble this problem.
I am running Windows Vista on my gaming rig :(
Since Vista cannot run programs in compatibility mode XP service pack 3 i tried running it in XP service pack 2...
Doing this it got to the launcher in under 10 seconds...
but because its Service pack 2 compatibility mode another error pops up that states the operating system is below system requirements... and the installer is stuck at 0%
I knew this would happen but my question is why it would launch in service pack 2 mode that is below system requirements and not in Vista?
Reply Quote
http://us.battle.net/d3/en/forum/topic/5151715572

That was my solution. Tried to make it as easy to understand as possible. Looking at this thread some people were able to just delete the cache folder and make it work. I had to remove both Blizz folders as well as enable secondary services. I would also recommend a reboot as putting it on automatic doesn't necessarily enable secondary services right away (put this in my post I linked).
Edited by Brucelee#1413 on 5/15/2012 11:46 PM PDT
Reply Quote
Posts: 1
this work 4 me thank you so much u the !@#$!!!!!!!!!
Reply Quote
Delfonz, you're my hero, thank you.
Reply Quote
95 Human Paladin
5975
Posts: 2
I've uploaded my working Battle.net files to see if it may help anyone. Feel free to test and let me know.

http://www.gamefront.com/files/21699449/D3+-+Battle.net+Files.zip

Place them inside: C:\ProgramData\Battle.net

Agent
Client
Setup


OMG!! Thankyou!!!!!!
your a champ.
Reply Quote
i only have an agent 524 - sometimes 2 others as well...so this solution doesnt work - nor does the other battlenet file (its from a disc game maybe thats why)
Reply Quote
85 Human Paladin
4535
Posts: 65
thanks that actually worked, I wish I came upon this post sooner, instead of wasting 18 hours trying to figure this crap out
Reply Quote
ty.tyty.

u safe my day!!!!
Reply Quote
Kool ill try this when i get home :-) hope it works
Reply Quote
Hello, I tried everything possible, from Delfon instructions, but still does not work .. : (F * ck I do not know what to do ... I have Win 7 64bit
Reply Quote
Posts: 1,037
View profile

internet options > Connections > LAN Settings > uncheck "Automatically detect settings"


This seems to have been the key step I was missing. Nothing else worked until I did this.
Reply Quote
Working!!! :))
Reply Quote
don´t workink :(
Reply Quote
90 Tauren Druid
8080
Posts: 2
I also have failed to get any solution to work for my gaming laptop despite trying everything I have found on the forums and elsewhere. I am also running Windows 7, 64 bit. However, success on my older desktop PC also running Windows 7, 64 bit. Have no idea why.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]