Diablo® III

Updating System Files.

Abe,

Are you sure you checked the Secondary Logon service as I described above? Your symptoms sound exactly like what having it disabled would cause.

____________________________________________________________________
Support Information Administrator


What if that doesn't work?
Same for the deleting the Battle.net file.
Reply Quote
Posts: 58
Afraid so, it was set to manual, I changed it to automatic just for kicks. No difference.

The update system files bar stops about 1/3 of the way and freezes
Reply Quote
Support Forum Agent
Posts: 40,339
Abe,

It's got to be a permissions issue then. Something's stopping files from being written to C:\Program\Battle.net.

Sometimes deleting the Cache folder in C:\ProgramData\Blizzard Entertainment\Battle.net can help so maybe try that next.

____________________________________________________________________
Support Information Administrator
Reply Quote
85 Tauren Druid
4495
Posts: 5
TYVM Omarakos, I spent days with earlier thread fixes but this one nailed it for me as I had the same problem as the OP with D3 retail and MoP beta.

Thanks for the post and support with the community.

"If you try running the Diablo III Setup.exe file and nothing appears to be happening, check to see if the Windows Service for Secondary Logon is enabled. The game requires it and will not run if it's disabled.

To check, open Control Panel > Administrative Tools > Services and scroll down to the Secondary Logon service. Right click it and select properties. Make sure the Startup Type is NOT set to Disabled. Any other setting is ok.

This service being disabled may also cause the system to appear to hang during the "Updating Setup Files" portion when run."
Reply Quote
Abe,

It's got to be a permissions issue then. Something's stopping files from being written to C:\Program\Battle.net.

Sometimes deleting the Cache folder in C:\ProgramData\Blizzard Entertainment\Battle.net can help so maybe try that next.

____________________________________________________________________
Support Information Administrator


This did not work.
Reply Quote
Posts: 58
Abe,

It's got to be a permissions issue then. Something's stopping files from being written to C:\Program\Battle.net.

Sometimes deleting the Cache folder in C:\ProgramData\Blizzard Entertainment\Battle.net can help so maybe try that next.

____________________________________________________________________
Support Information Administrator


Yes I've heard of this solution several times as well, the main issue here, is that C:\ProgramData\Blizzard Entertainment\Battle.net is nowhere to be found on my hardrive.

Looking for it manually, it just isnt there. Using the search command, it just isnt there.
Reply Quote
Support Forum Agent
Posts: 40,339
Abe,

What Operating system are you using?

____________________________________________________________________
Support Information Administrator
Reply Quote
Posts: 58
Abe,

What Operating system are you using?

____________________________________________________________________
Support Information Administrator


Windows 7
Reply Quote
Support Forum Agent
Posts: 40,339
Abe,

Ok, C:\ProgramData is hidden by default. You'll need to change a Windows setting so you can see hidden files and folder. To do so, click your Windows/Start button, select 'Control Panel' from the menu, then 'Appearance and Personalization', then 'Folder Options'. Next click the 'View' tab, scroll down the list and look for the option 'Hidden files and folders', make sure this is set to Show hidden files and folders.

Delete the C:\ProgramData\Battle.net folder while you're at it too.

____________________________________________________________________
Support Information Administrator
Reply Quote
Posts: 13
when i whent to the secondary option it wasent even diabled it was set in automatic but just to be sure i tryed every single option before i restarted it again and as for the battle net folder it wont allow me to delete it says it being used somewhere else even though i dont have it open anywhere else i dont have anything open during this process........ ok sorry i whent back and deleted the task manager thing running in the backround and it allowed me to delete the battlenet folder now but still it is getting stuck at the exsact same point
Edited by Nightmare#1712 on 5/10/2012 5:45 PM PDT
Reply Quote
Support Forum Agent
Posts: 40,339
nightmare,

Reboot and try deleting it.

____________________________________________________________________
Support Information Administrator
Reply Quote
Posts: 58
Abe,

Ok, C:\ProgramData is hidden by default. You'll need to change a Windows setting so you can see hidden files and folder. To do so, click your Windows/Start button, select 'Control Panel' from the menu, then 'Appearance and Personalization', then 'Folder Options'. Next click the 'View' tab, scroll down the list and look for the option 'Hidden files and folders', make sure this is set to Show hidden files and folders.

Delete the C:\ProgramData\Battle.net folder while you're at it too.

____________________________________________________________________
Support Information Administrator


Well I managed to find the folder thanks to your guidance, and promptly deleted it.

Upon tryin the installer one more time, it reached the 1/3 mark where it usually freezes, and to my joy, it kept going... until it reached 2/3, where it again, freezes.

So close, and yet so far.
Reply Quote
Abe,

Ok, C:\ProgramData is hidden by default. You'll need to change a Windows setting so you can see hidden files and folder. To do so, click your Windows/Start button, select 'Control Panel' from the menu, then 'Appearance and Personalization', then 'Folder Options'. Next click the 'View' tab, scroll down the list and look for the option 'Hidden files and folders', make sure this is set to Show hidden files and folders.

Delete the C:\ProgramData\Battle.net folder while you're at it too.

____________________________________________________________________
Support Information Administrator


Well I managed to find the folder thanks to your guidance, and promptly deleted it.

Upon tryin the installer one more time, it reached the 1/3 mark where it usually freezes, and to my joy, it kept going... until it reached 2/3, where it again, freezes.

So close, and yet so far.


This is were my issue is, at 2/3
Reply Quote
Posts: 58


Well I managed to find the folder thanks to your guidance, and promptly deleted it.

Upon tryin the installer one more time, it reached the 1/3 mark where it usually freezes, and to my joy, it kept going... until it reached 2/3, where it again, freezes.

So close, and yet so far.


This is were my issue is, at 2/3


yay we're in a club ^^ I think people in our situation should get an in game achievment to recognize our extra hardships to play the game lol
Reply Quote
Support Forum Agent
Posts: 40,339
Abe ,

It can sit there for a couple of minutes working and appear to freeze, let it run a little while.

Did you delete both folders I mentioned or just the Cache folder?

____________________________________________________________________
Support Information Administrator
Reply Quote
Posts: 58
Abe ,

It can sit there for a couple of minutes working and appear to freeze, let it run a little while.

Did you delete both folders I mentioned or just the Cache folder?

____________________________________________________________________
Support Information Administrator


I deleted the Battle.net folder located in ProgramData.

I'll let the updater run a little longer just to rule it out, but it doesnt appear to be doing anything.

Appreciate the assistance btw
Reply Quote
Abe ,

It can sit there for a couple of minutes working and appear to freeze, let it run a little while.

Did you delete both folders I mentioned or just the Cache folder?

____________________________________________________________________
Support Information Administrator


I did both.
Reply Quote
Posts: 58
Abe ,

It can sit there for a couple of minutes working and appear to freeze, let it run a little while.

Did you delete both folders I mentioned or just the Cache folder?

____________________________________________________________________
Support Information Administrator


I did both.


same, just deleted both.

Once again, it goes 2/3 and stops, i let it run for over 5 minutes, pretty sure its not responding
Reply Quote
Support Forum Agent
Posts: 40,339
Abe,

Are you right clicking the downloader file and selecting Run as an admin each time?

____________________________________________________________________
Support Information Administrator
Reply Quote
68 Undead Warlock
0
Posts: 7
It seems that the agent executables are having a hard time shutting themselves down and that's probably why it's messing the whole update thing..
God.. This is so frustrating.. =/
Well.. I'm getting myself some sleep.. I've got a headache.. Hope you guys figure it out.
Good luck!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]