Diablo® III

"An unexpected error occurred while trying to

People with this problem, can you notice on your EULA that all the links are for EU forums?
Could this be our problem?
Somehow we have the EU installer with other home locations?
Reply Quote
90 Tauren Shaman
17120
uninstall the beta
install new game client from blizz
this worked for me
Reply Quote
Same problem, Win 7 64 Vancouver BC.

@Psi I also do have the EU EULA
Reply Quote
had the client fully downloaded, decided to redownload the downloader from battle.net, it checked the files and now there is a 0.05gb addition that is taking !@#$ing forever to download
lets hope thats the fix!
Reply Quote
I think I found out my problem. I apparently downloaded the UK version and not the US version. Check to make sure that you have the correct version of the installer downloaded.
I'm starting to DL it again and hopefully that will fix my problem
Reply Quote
EU EULA as well.

Beta was removed well before Launch...maybe I'll pull down the installer again, just for fun......:(
Reply Quote
Yup, downloaded the edition from my account page, now its working.
Reply Quote
@Powerlad, I uninstalled the beta weeks ago.
Reply Quote
I think I found out my problem. I apparently downloaded the UK version and not the US version. Check to make sure that you have the correct version of the installer downloaded.
I'm starting to DL it again and hopefully that will fix my problem
Yup seems like this is also my problem, as my region is set to global, WTF?
How do I change my region?

NM Figured that out.
Weee 7.6 gigs on a !@#$ty work internet connection.
THIS WONT BE SLOW AT ALL :S
Edited by Psi#1697 on 5/14/2012 8:36 AM PDT
Reply Quote
same, central canada, windows 7 64 bit
Reply Quote
62 Blood Elf Death Knight
11400
I just had a look and it seems mine was set to 'enGB' by default rather than US, nice one.
Reply Quote
You need to download the US version.
Just went to my battle.net page and found that the region/language was default EU

Takes a second, just redownload it and it'll start installing
Reply Quote
I think I found the problem....

Check in your D3 installation folder see if you have a file with an extension .part

IF YOU DO...

that means that the download is missing just a few megas...

go to the bnet home page then account then your game select diablo and click to download the digital version...

Select the same folder you installed it into before and it will check see how much you have left to download let it finish then run the setup again

THIS JUST SOLVED THE PROBLEM FOR ME
Reply Quote
win 7 64bit australia same issue
Reply Quote
So, re-downloading worked for me. However instead of Downloading all the installer content again,I just renamed the Download folder from enGB to enUS.. Seems to be working!
Reply Quote
90 Human Paladin
6580
Getting the same thing here. AU East
Downloaded client last Wed, checked with the updater and it went through all 7.60 GB's.
Reply Quote
I think I found out my problem. I apparently downloaded the UK version and not the US version. Check to make sure that you have the correct version of the installer downloaded.
I'm starting to DL it again and hopefully that will fix my problem


Looks like I was right. At least I'm getting good throughput on the DL. 3.32MB/s shouldn't take too long to get this down

<edit> And now my DL speed has plummeted :/
Edited by CBFTW#1314 on 5/14/2012 8:42 AM PDT
Reply Quote
thank you @siarrah that totally worked for me :)
Reply Quote
90 Human Priest
6485
I have the enGB downloader I live in Canada so all you that say you changed the downloader would you care to give a little info on how to get the north american one, instead of just saying you changed it and it worked.
Reply Quote
85 Gnome Death Knight
4395
My problem was solved in the same way as CBFTW. Need to install the correct Full Game Client for your region (mine was English (SG) as I'm in Singapore). It seemed to default me to the EU version of the client. You need to change it under your Game Client downloads. The option to change is just under the words "Full Game Client" under the D3 header.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]