Diablo® III

"An unexpected error occurred while trying to

85 Draenei Priest
9555
Posts: 49
On Windows 7 - 64 bit I did the following to install Diablo 3 when the pre-installer failed:

  • Opened Task Manager and shutdown Agent.exe *32 and the Diablo installer if it was running
  • Deleted directory "C:\ProgramData\Battle.net"
  • Log into Battle.Net Account Management and download the Diablo III installer - "Diablo-III-Setup-enUS.exe"
  • Run Diablo-III-Setup-enUS.exe and follow the prompts

  • This process means that you must re-download all of Diablo III again (8.19 GB) but it does work and at least there is still time before launch.

    NOTE: I did follow all of Blizzards instructions to try and fix the pre-installer download but none of them worked. This is the only thing that worked for me, so don't be afraid to try Blizzards fixes first. I had .part files but the pre-installer would not fix them up. It would just start the installation and fail.

    Good Luck.

    EDIT: Just finished downloading with the release installer and it all went great. Could launch D3 watch the opening cinematic and login (though Battle.net is not accepting D3 logins atm of course).
    Edited by wulfsiege#6432 on 5/14/2012 7:13 PM PDT
    Reply Quote
    Same here, win 7, 64 bit, New Zealand
    Reply Quote
    All I did was follow this. Even tho I live in Brazil and I thought I had de US installer, apparently I did not.

    So I went to this page http://eu.battle.net/d3/en/blog/4410912/ where Blizz gave the solution. It worked for me, so I am downloading.


    worked like a charm @ Bengay

    getting the new enGB installer fixes the error
    Edited by Shazam#1513 on 5/14/2012 6:16 PM PDT
    Reply Quote
    85 Orc Rogue
    4390
    Posts: 16
    well it happened to me some im redownloading the hole thing gonna take me 9 hrs :/ hope this 1 works other wise ill have to just keep re downloading it till it lets me install it!
    Reply Quote
    Posts: 479
    I think I found the problem....

    Check in your D3 installation folder see if you have a file with an extension .part

    IF YOU DO...

    that means that the download is missing just a few megas...

    go to the bnet home page then account then your game select diablo and click to download the digital version...

    Select the same folder you installed it into before and it will check see how much you have left to download let it finish then run the setup again

    THIS JUST SOLVED THE PROBLEM FOR ME


    This is working for me so far. Thanks Siarrah!!
    Reply Quote
    85 Blood Elf Mage
    12285
    Posts: 1
    Win 7 here in Canada :(
    Reply Quote
    Posts: 7
    Same

    Australia Windows 7 64 bit
    Reply Quote
    87 Human Paladin
    0
    Posts: 1
    new zealand windows 7 64bit same message
    Reply Quote
    A bit disappointing that I have to re-download 8 GB to get this to work. Wanted to start playing at 12am sharp with my friends, now im stuck downloading for an hour or two...Blizzard Fail #1...not off to a good start...this is what we get for pre-purchasing...
    Edited by Smarticus#1472 on 5/14/2012 9:34 PM PDT
    Reply Quote
    38 Worgen Rogue
    280
    Posts: 13
    Same here. Windows 7, 64 bit, Brazil, Bauru, São Paulo
    Downloading client again.
    Reply Quote
    Japan windows 7 64bit same error massage
    Reply Quote
    Posts: 25
    Same BUT after I closed it out and restarted the DVD it worked!

    Windows 7 64 bit
    Reply Quote

    Please report any Code of Conduct violations, including:

    Threats of violence. We take these seriously and will alert the proper authorities.

    Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

    Harassing or discriminatory language. This will not be tolerated.

    Forums Code of Conduct

    Report Post # written by

    Reason
    Explain (256 characters max)

    Reported!

    [Close]