Diablo® III

L A U N C H E R P R O B L E M ! ! !

85 Goblin Warrior
8285
Posts: 5,698
I installed diablo 3 fully just fine. I hit play after it was completed and it stayed at the launcher forever. I exited out and restarted up D3 again and it goes to the launcher screen and says UPDATING BLIZZARD LAUNCHER 0% and it wont move. Is it supposed to be like this ? is anyone having the same problem ? PLEASE HELP !!!

jeff
Reply Quote
Posts: 6
Have the same problem there is another post about this, several people have this problem. Not a single blue response though. . . I created a ticket on battle.net
Reply Quote
while the launcher is at 0%

open task manager and kill the agent.exe process

i should reappear and if you do it 2-3 times it should start working.
Reply Quote
85 Goblin Warrior
8285
Posts: 5,698
while the launcher is at 0%

open task manager and kill the agent.exe process

i should reappear and if you do it 2-3 times it should start working.


WOW THIS WORKED. THANK YOU SO MUCH !
Reply Quote
85 Goblin Warrior
8285
Posts: 5,698
Bump !
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]