Diablo® III

SOLVED: Slow download issues.

I did this and I am sitting at 370 KB/S

Is my internet just fail?

Any ideas?
Reply Quote
THANK YOU!!! :D This took me from 20Kb/sec to 1.5Mb/sec !!
Edited by Tet5uo#1550 on 5/14/2012 9:33 AM PDT
Reply Quote
85 Blood Elf Warlock
8595
Worked for me as well. Thanks.

I did this and I am sitting at 370 KB/S

Is my internet just fail?

Any ideas?


Likely so. Do you frequently get faster than that with non-blizzard downloads?
Reply Quote
wow, someone make this guy a sandwich!! LOL
Reply Quote
Wow, I'm glad this helped so many people. Cheers guys, enjoy 12:01!

(Still curious what that setting does to remedy the problem lol, I have no idea why it works. Apparently that check box enables WPAD, not sure why it would interfere, but if you are curious: http://en.wikipedia.org/wiki/Web_Proxy_Autodiscovery_Protocol )
Edited by Wr3k#1755 on 5/14/2012 11:00 AM PDT
Reply Quote
Solved:

Ok, so I went into: control panel>Internet options>connections>LAN settings and unchecked the "Automatically detect settings" box and my downloaded instantly started peering properly and my download speeds went to 3MB/s.

Why would this fix the problem? Can anyone explain?


If i ever see you in game im giving you like a million gold
Reply Quote
WOW!! sir you = win! i just went form 10 KB/S to 2.0 MB/S! you'd think Blizzard would of had the fix for this problem haha!!!
Reply Quote
Thanks! No idea on why that worked tho.
Reply Quote
41 Goblin Priest
12600
Solved:

Ok, so I went into: control panel>Internet options>connections>LAN settings and unchecked the "Automatically detect settings" box and my downloaded instantly started peering properly and my download speeds went to 3MB/s.

Why would this fix the problem? Can anyone explain?


I love you.
Reply Quote
Nice fix! Was stuck at less than 20kb/s and as soon as I changed this option it was finished in less than 10 seconds. This fix really should be in a stickied thread somewhere.
Reply Quote
Went from downloading literally nothing for a few hours (as I had to uninstall due to a corrupt installation), to plugging along at a dependable 3Mb/s. Kudos. Odd fix, but it worked.
Reply Quote
90 Human Mage
17135
Wish that worked for me that is all any one says now and it DOES NOT work for me but i sitll get like 1 byte download so i just have to wait for the CD.
Reply Quote
05/14/2012 02:48 PMPosted by Rayo
Wish that worked for me that is all any one says now and it DOES NOT work for me but i sitll get like 1 byte download so i just have to wait for the CD.
Have you tried port forwarding? I did that right before I came here and unclicked, so that may interact with this fix in some way.
Reply Quote
90 Human Mage
17135
05/14/2012 02:49 PMPosted by Berkilak
Wish that worked for me that is all any one says now and it DOES NOT work for me but i sitll get like 1 byte download so i just have to wait for the CD.
Have you tried port forwarding? I did that right before I came here and unclicked, so that may interact with this fix in some way.


Yep I've done everything the blues said once then they kidna just went away GG on that customer help
Reply Quote
90 Blood Elf Rogue
7885
Bless this post.
Reply Quote
Still not getting great speeds, but a drastic improvement none the less. Thank you!
Reply Quote
85 Blood Elf Death Knight
1560
Worked for me too! :)
Reply Quote
From 300kb to 7mb ! Thanks man!
Reply Quote
90 Human Paladin
9570
I took a nap for 2 hours. Was only at 10%. Did that and now I'm at 16%, I wouldn't of made Launch if it wasn't for you. Thank you sir.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]