Diablo® III

Stuck at "LAUNCHING..."

73 Orc Hunter
4540
Posts: 54
Everytime I open the loader it goes through an "updating files" thingy, after it's done and I hit "play" it gets stuck at "Launching..." and the game never opens.

What's up with that?
Reply Quote
Posts: 3
CTRL+ALT+DELETE
go to processes tab. Stop "Agent.exe" restart your installer/launcher. Worked for me.
Reply Quote
Posts: 15
Doesn't work for me.
When i stop agent.exe, restarting the installer/launcher prompts a "Updating tools (0%)" text
Reply Quote
73 Orc Hunter
4540
Posts: 54
Thanks for the help, but it didn't work for me =(

Here's exactly my problem.

Once I open the loader it gets stuck in Updating Tools 0%. I then close the agent.exe so that it gets unstuck. It reopens agent.exe and starts Updating Tools. Then it loads a red bar of Updating Files which has xxx/14474 files on it. Then an yellow bar of Updating Files which has xxx/611 files on it. Then I can click play. Once I click play, I get stuck at "Launching...".

I've tried many things with agent.exe and none of them solved.
Reply Quote
Posts: 15
lol, i've been having this error since the beta period.
I had to reinstall the game multiple times after every beta update.
I'm quite surprised they didn't fix this yet. God
Reply Quote
73 Orc Hunter
4540
Posts: 54
I had some issues with agent.exe on beta too. But closing it many times seemed to work back then.
Reply Quote
73 Orc Hunter
4540
Posts: 54
The game just opened to me and I don't know why. Gotta use brute force. Close that !@#$ty bad programmed agent.exe a gazillion times and keep reopening your launcher untill it works.
Reply Quote
i have the same issue.
Reply Quote
Same issue on my end. I vaguely recall something similar from the beta, but that got fixed.
Edited by Slaunyeh#2734 on 5/14/2012 9:31 PM PDT
Reply Quote
I fixed the problem! Go to your Diablo III folder, create a new folder, name it backup, move the folder labeled Updates to this backup folder. Start client. Worked for me.
Reply Quote
Posts: 112
Thank Desi.. your fixed worked for me.. looks like whatever i downloaded was probably corrupted.. had to kill agent.exe and the downloader and then run the update in administrator
Reply Quote
Posts: 1
this worked for me too, thanks Desi! When you move the files to the backup folder and relaunch the downloader, it'll try to redownload the missing file (critical, u wont be able to launch without it). After this is done, i was able to enter the game and not stuck on launching.

FYI in the main menu, blizzard team says they are doing emergency maintenance though, so alot of accounts wont be able to log in, etc. So this will probably all be fixed soon.
Reply Quote
90 Troll Druid
10710
Posts: 287
still having same issue, didn't work for me =(
Reply Quote
Posts: 8
Desi, your fix worked for me! Had to kill the agent.exe process a few times, and restart the Diablo III Launcher.exe a few times, but it finally worked. If you're stuck at Updating Tools (0%), try stopping the agent.exe process and it should start downloading the right tools. If it's still stuck, just keep restarting the Diablo III Launcher.exe and agent.exe; brute force is the only way in.

Now I finally get in after 7 hours of troubleshooting, and the Battle.net servers are down. Holy crap terrible launch.
Reply Quote
Well after my comp restarted on me now i can tget it to launch again...
Reply Quote
I'm having the exact same problems Idk if it's not updating 'cause the servers are down for diablo 3 or what... But this seems to be the most comlicated game I've ever had to install...
Reply Quote
kudos on that, worked, ty
Reply Quote
Try to install the newest VGA driver. I had the same problemas you, but that fixed to me.
Reply Quote
Cheers guys, didn't realise I just paid 40 quid for the beta! :)
Reply Quote
Try adding Agent.exe, Diablo III.exe, and Blizzard Launcher.exe to your virus protection's exceptions. This resolved said issue for me with AVG on XP x64.

If it doesn't seem to work at first, try closing out Blizzard Launcher.exe and Agent.exe through the task manager, then wait 20 to 30 seconds and try starting the game through the launcher again.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]