Diablo® III

Updating Setup Files AGAIN.

85 Blood Elf Paladin
7175
Posts: 22
Another voice in the choir here.

I'm having the same problem as many others on this board are having. No listed action has had any response to what is happening. I've tried downloaded new agent files, changing compatibility modes, redownloading the game, shutting off the firewall/antivirus, adding exceptions to the firewall, deleting the battle.net folder, running agent while the setup is running. You name it, and chances are, I've tried it.

Here's the kicker though: I got the setup files working and reached the launcher yesterday. So imagine my surprise that when I woke up to download the patch this morning before work, and I couldn't reach the launcher.

After fiddling with it some more this afternoon, the setup has reached the point where it will reach anywhere between 60-90% complete, and even saying that it's going to run the Diablo 3 launcher before it will actually lose the progress it had and start over from around 40%.

What can I do about this? This seems like something that should have been fixed in beta. We're less than 24 hours away from launch here in the US and this is more than a little frustrating.
Reply Quote
85 Blood Elf Paladin
7175
Posts: 22
Bump!

I would like to get some sort of input on this!
Reply Quote
90 Human Paladin
13270
Posts: 8
The Updating Setup is happening to me right now. And im not sure how to fix it either!
Reply Quote
85 Blood Elf Paladin
7175
Posts: 22
It's frustrating, to say the least!
Reply Quote
90 Human Paladin
13270
Posts: 8
Yeah i have no idea what to do. And i want to have the game for the release tonight.
Reply Quote
85 Blood Elf Paladin
6890
Posts: 3
Yup I'm in safe mode and running at as admin and it is still doing the same thing. Really really annoying.
Reply Quote
85 Blood Elf Paladin
7175
Posts: 22
I wonder what prompted the change from the old installers that WoW and Starcraft 2 have. Those worked perfectly fine. What does this new one bring to the table besides a myriad of errors?
Reply Quote
90 Human Paladin
13270
Posts: 8
I totally agree. This is really Annoying right now..
Reply Quote
85 Blood Elf Paladin
7175
Posts: 22
Update:

it works if I use it in compatibility mode for service pack 1 for XP. (I have Vista!) However, cruel installer that it is -- it can't download with service pack 1.

So I switch off compatibility mode for SP1 and it gets stuck around 60% again.
Reply Quote
85 Blood Elf Paladin
7175
Posts: 22
BUMP.

I would like to play this tonight. Thanks.
Reply Quote
Posts: 2
I had this exact same problem in beta with trying to update the game. Tried changing the compatibility to Windows XP Service Pack 3 when beta was out and the updater finally went through. However this trick doesn't work with the retail version of the game. Having the exact same problem as you. I mean I would expect something like this in the beta but retail come on.. just sad.

Haven't found a solution yet, and most treads from the beta have been locked or not found when looking for a solution. I wont be to happy if tomorrow after work I get the same issues and have to sit on the phone with there support line, and probably not get an answer.
Edited by Fenix#1559 on 5/14/2012 7:20 PM PDT
Reply Quote
I keep getting the same "decryption error" message and I'm at the end of my bandwidth limit (20GB) for the month. Every frickin GB after that costs me an extra $10. i don't want to have to download again because Blizzard can't get it's act together and make this work on the first time.
Reply Quote
Posts: 185
Bump. If this isn't fixed I apparently won't be playing tonight :(
Reply Quote
Posts: 435
bump
Reply Quote
36 Worgen Warlock
100
Posts: 15
Same here, I think I have tried just about every solution. I had the same issue with the Beta, so never played it. I'm really regretting that I purchased this as a digital download right about now. And I really regret I've wasted several hours messing around with numerous workarounds today.
Reply Quote
isn't it possible to have a blue post here to help us? I just bought the digital version and I can't get past the "Diablo 3 Setup" either
Reply Quote
Same issue here. In the beta I remember I got it working by downloading certain game files that someone had posted and then copying and pasting them into my Battle.Net directory.
Reply Quote
Posts: 10
I have the same issue, and ive been trying to fix it for 4 hours. Ive tried everything including enabling secondary as automatic. The beta installed perfectly smoothly for me, now this?? Not cool.
Reply Quote
90 Dwarf Shaman
8450
Posts: 88
Me too Dank. I have done them all with no luck.
Reply Quote
85 Goblin Warlock
7040
Posts: 2
ya I am also having major problems with D3, iv downloaded it like 6 times and it still just stays on UPDATING SETUP FILES! i would really like to play for launch tonight, can anyone help me?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]