Have a question, that I can't seem to find an answer to. A couple months ago, one of my friends let me download the D3 beta to my computer and use his account to test it out. My computer was fairly old and when installing the beta it came up with the your system is below minimum system requirements, having a processor that was below 2.8 Ghz. BUT, after clicking OK, it still managed to install just fine and actually ran smoothly at low settings. So, my questions is, even if your processor is below minimum requirements, shouldn't you still be able to install it? It's like maybe a semi-dangerous swimming zone - swim/play at your own risk?