I get an error message telling me I need to meet min req. for D3 and that i need a new OS. I have windows 7 and my computer is better than min req. why is this message being displayed.