Diablo® III

Downloading randomly stops

Hey, I bought the digital version, and I'm trying to DL the client. What's happening is kind of strange/ random.

The client will start downloading no problem at between 1mb - 2mb. It will do this for a random amount of time, then suddenly stop. I've watched the connection info during this.

First it shows the DL gaining more and more...seeds?.. Different places to download from, and the speed increases. Then suddenly ALL of those seeds disappear, and my download rate goes to 0.0. It sits there doing nothing until I close it, and restart the installer. Then it starts from where it left off, downloading again before losing connection at a random time.

I don't have a firewall or antivirus on, and I've tried running it both as admin and not admin. My internet connection is absolutely stable and never has issues. It's def the installer's issue.

If there's any around this, please let me know. I've been doing it for a while now, and I'm only at about 10%.

EDIT: Just tried turning off p2p and the the throttling option. Still no difference.
Edited by Maverick#1992 on 5/11/2012 6:57 PM PDT
Reply Quote
Support Forum Agent
Maverick,

I would guess your ISP may be detecting the "torrent" activity and blocking it. Try turning off the peer to peer feature in the downloader's preferences.

____________________________________________________________________
Support Information Administrator
Edited by Omrakos on 5/11/2012 6:58 PM PDT
Reply Quote
I actually tried that already, unfortunately. Still no luck. Torrents always seem to work for me.
Reply Quote
I also notice in the connection info that the seeds i'm downloading from disappear then reappear, switching in diff ones almost every second. All this is happening while it's downloading, before they all just disappear at once.
Reply Quote
Support Forum Agent
Maverick,

The ISP is all I can come up with unfortunately. You'd need to connect from another location to see though. It sounds like your connection is plenty fast as is. I know it's a hassle but I think I'd just keep restarting it until it completes. It shouldn't take long if you're getting the speeds you mentioned.

____________________________________________________________________
Support Information Administrator
Reply Quote
Fine.. but my love for you has shrunk 1/18th.
Reply Quote
Alright It's been 7 hours... I'm at 7.20 out of 7.60 gb's, and it stops after a second, and i have to restart.. It's not finishing..

I highly doubt it's my ISP that has a specific issue with this one game.

EDIT: To be clear, restarting it over and over again is no longer making any progress.
Edited by Maverick#1992 on 5/12/2012 4:20 AM PDT
Reply Quote
Update: During one of my attempts I was watching the log, and before I randomly got KICKED out of the download this time (which is a first for me btw, great installer) I saw a line that said something about Installer tombe 2 , and a bad request error 400, or something of that sort. Didn't have a chance to copy and paste it.

Also, I managed to get to 97% before it restarted, but when I start it up again, I'm back at 95% every time, regardless of when it stops.
Edited by Maverick#1992 on 5/12/2012 5:36 AM PDT
Reply Quote
OK! SO! This is the error it gives me in the log when all of my seeds disappear.

05/12/12 05:39:57.4820 Http request error occurred (400 Bad Request): http://attdist.blizzard.com/d3/1.0.0.500/Diablo-III-8370-enUS-Installer/Diablo III Setup.app/Contents/Resources/d3icon.icns

05/12/12 05:40:18.5390 File Error: Diablo-III-8370-enUS-Installer file () error: file too short

The file too short one is what made my seeds disappear. So now we know the error. Please help me.
Reply Quote
59 Undead Death Knight
9320
Update: During one of my attempts I was watching the log, and before I randomly got KICKED out of the download this time (which is a first for me btw, great installer) I saw a line that said something about Installer tombe 2 , and a bad request error 400, or something of that sort. Didn't have a chance to copy and paste it.

Also, I managed to get to 97% before it restarted, but when I start it up again, I'm back at 95% every time, regardless of when it stops.

The bad request (400) is weird, not sure why it happens. It was happening to me when trying to get the HTTP header of those files.

http://us.battle.net/d3/en/forum/topic/4903180666#9 (direct http links)
Keep any files you've finished downloading, download the ones you need and delete the .part ones.

Edit: And ignore the Mac files. Unless you're actually going to install the client on a Mac.
Edited by e1D#1473 on 5/12/2012 5:46 AM PDT
Reply Quote
Thank you very much for the response. The thing that worries me though is trying to get the patch that I hear is coming out on Monday, or if they happen to have a quick patch on tuesday during the launch. I don't want to be screwed because I can't DL a quick 100 mbs or so, which is my current problem.

EDIT: Just got this one trying it again.

05/12/12 05:59:20.8290 Http request error occurred (400 Bad Request): http://blizzard.vo.llnwd.net/o16/content/d3/1.0.0.500/Diablo-III-8370-enUS-Installer/external_resources.rcc

Really don't know what the heck is going on here.... Been at this for about 10 hours straight.. Driving me bonkers.
Edited by Maverick#1992 on 5/12/2012 6:00 AM PDT
Reply Quote
59 Undead Death Knight
9320
Thank you very much for the response. The thing that worries me though is trying to get the patch that I hear is coming out on Monday, or if they happen to have a quick patch on tuesday during the launch. I don't want to be screwed because I can't DL a quick 100 mbs or so, which is my current problem.

EDIT: Just got this one trying it again.

05/12/12 05:59:20.8290 Http request error occurred (400 Bad Request): http://blizzard.vo.llnwd.net/o16/content/d3/1.0.0.500/Diablo-III-8370-enUS-Installer/external_resources.rcc

Really don't know what the heck is going on here.... Been at this for about 10 hours straight.. Driving me bonkers.

The patch will be downloaded through the launcher. I dont think it will be an issue.
Reply Quote
Thank you very much for the response. The thing that worries me though is trying to get the patch that I hear is coming out on Monday, or if they happen to have a quick patch on tuesday during the launch. I don't want to be screwed because I can't DL a quick 100 mbs or so, which is my current problem.

EDIT: Just got this one trying it again.

05/12/12 05:59:20.8290 Http request error occurred (400 Bad Request): http://blizzard.vo.llnwd.net/o16/content/d3/1.0.0.500/Diablo-III-8370-enUS-Installer/external_resources.rcc

Really don't know what the heck is going on here.... Been at this for about 10 hours straight.. Driving me bonkers.

The patch will be downloaded through the launcher. I dont think it will be an issue.


Unfortunately it's the launcher that is giving me the issue. :/ The size of the patch will be about the size of what I'm trying to download now. Just don't want to miss out on launch day.
Reply Quote
59 Undead Death Knight
9320

The patch will be downloaded through the launcher. I dont think it will be an issue.


Unfortunately it's the launcher that is giving me the issue. :/ The size of the patch will be about the size of what I'm trying to download now. Just don't want to miss out on launch day.

No, that's the installer downloader.

Which files are still being downloaded (still named .part)? And if you're going to install the Windows client, you dont need the files in the "Diablo III Setup.app" folder.
Reply Quote
Oh.. So that makes me feel a lot better than. I didn't want to have to break the internet in a rage and get everyone else using it all upset n' stuff. Thanks for your help man, much appreciated!
Reply Quote
Seems as though if I try to move the client, that's when it freezes.

Still having the DL issue though, but I downloaded the files directly.

Hope it can be fixed either way.
Edited by Maverick#1992 on 5/13/2012 2:02 AM PDT
Reply Quote
maybe blizzard can upload the individual files into a more easy DL thing and we can just manually DL each section then combine it into one giant folder.
iono if that would work?
seems like everyone is being stuck on different parts of the download
Reply Quote
90 Orc Hunter
8265
Having this problem too.
IDK how to fix it, driving me to the rage :|
Reply Quote
85 Blood Elf Paladin
6940
Also happening to me. Download works for around 5 minutes then completely disapears
Reply Quote
90 Orc Hunter
8265
Here is a part of the log that explain the problem:

05/13/12 23:21:24.4316 Http request error occurred (400 Bad Request): http://ak.worldofwarcraft.com.edgesuite.net/d3/1.0.0.500/Diablo-III-8370-enUS-Installer/Installer Tome 2.MPQE

05/13/12 23:21:31.1399 Http request error occurred (400 Bad Request): http://attdist.blizzard.com/d3/1.0.0.500/Diablo-III-8370-enUS-Installer/Installer Tome 2.MPQE

05/13/12 23:21:32.5909 Http request error occurred (400 Bad Request): http://blizzard.vo.llnwd.net/o16/content/d3/1.0.0.500/Diablo-III-8370-enUS-Installer/Installer Tome 2.MPQE



Some friends keep saying this is caused to a route problem.
Maybe the downloader is blocking some routes, dunno if this is true.
Edited by Gaar#1349 on 5/13/2012 7:35 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]