Diablo® III

FPS question

Posts: 786
Just picked up an Nvidia GeForce GTX 560 Ti. FurMark scores seemed lower than I expected, 20 FPS average on 15m burnout test running on 1920x1080. My previous card was about 2 years old, was able to run D3 beta on ultra but had minor FPS issues. Will this new card give me the extra juice I need to have max FPS on ultra?!
Reply Quote
3 flavors of 560s and you now have the middle one.

What is your OLD card?

Any 560 should run D3 fine, I would not say it's ULTRA, it's not a game with super fine graphics nitpicky settings like MMOs tend to have, very limited options, at least in the beta, I couldn't even tell LOW from HIGH settings, there is no MAX FPS.... You really just want the same as your monitor refresh rate, which is likely 60, or 30 on a lower end rig is fine.

If you let the video card go higher, it's going to run higher temps all the time unnecessarily, and possibly wear out/break faster.

See GPU-Z at cpuid.com to keep tabs on it, or a Windows 7 video card temp meter gadget.
Edited by Badfinger#1431 on 5/12/2012 8:43 PM PDT
Reply Quote
Posts: 37
I played the beta with a 560 Ti and it was fine. On ultra, I think the lowest fps I ever saw was in the mid 30s. But I upgraded to a GTX 670 over the weekend just in case.
Reply Quote
Posts: 5
05/13/2012 02:00 AMPosted by Timbo
I played the beta with a 560 Ti and it was fine. On ultra, I think the lowest fps I ever saw was in the mid 30s. But I upgraded to a GTX 670 over the weekend just in case.


Just got my 670 as well, love it to death

edit: But not a quick death...
Edited by Brutang#1547 on 5/13/2012 8:25 PM PDT
Reply Quote
I'm running a GTX 560Ti and I sometimes get 60 but most of the time (90%+) I'm locked at 30 FPS. It's jittery, kinda feels like internet lag, I have MSI Afterburner installed and it's showing 30 :(

Settings: Maxed, VSync On, Max FPS Fore/Back Off.

Hardware: 8GB 2133 RAM - i5 2500K - 120 GB SSD - Win7 Pro x64

Anyone know why I'm getting such lacking performance on just Diablo 3? This should be more than enough to run this game.
Reply Quote
Posts: 1
Im getting the same problem. I have a GeForce 220, 2.4x2 intel, 4gb ram dd2 and im getting good and bad fps every here and there. If i go to windowed it goes to 60 and when i go to fullscreen it goes to 30. Anyone else know whats going on?
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Turn off VSync (to both of you two above me), and your graphics card is weak (to the guy just above me), by the way.
Edited by Ehrengarde#1143 on 5/16/2012 7:11 PM PDT
Reply Quote
560 ti here as well. I have kept fraps running to confirm my framerate (which stays at 60), though the game often appears choppy. I have a hunch this is caused by server lag.
Reply Quote
I have the evga 670 god it's is so sweet love the graphics card
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]