I have a 6 month old custom built PC with Windows 7 Home Premium. I get this error and it says "Diablo III requires a newer operating system to run."

My account is emailaddresshere!@gmail.com (if GM can view my account details)
Digital Pre-purchase

Please help getting this to run.