Diablo® III

Really slow Diablo III download speed

Worked for me also. Thanks a TON Xinthar! i owe you a beer!
Reply Quote
90 Goblin Death Knight
9760
Posts: 27
In order to resolve this issue, I had to do the following:

Go to Control Panel > Network Connections > Internet Options > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"

This changed my download speed from 56kbps to over 3mbps.


This fixed my problem as well.


Mine as well. Went from 50 kb/s to connection max
Reply Quote
Posts: 60

For those that don't use Windows XP/Internet Explorer:


Here is the registry entry to disable proxy discovery.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

ProxyEnable = 0
Reply Quote
Posts: 7
Thank you! Went from 20Kbs to 3.0MBps!
Reply Quote
85 Night Elf Rogue
3120
Posts: 3
thank you a million times over!

my download is finally moving and not at a standstill anymore! :D
Reply Quote
mines done 4gb in 5 hours :(
Reply Quote
Posts: 21
also having the same problem, anyone find a fix yet
Reply Quote
In order to resolve this issue, I had to do the following:

Go to Control Panel > Network Connections > Internet Options > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"

This changed my download speed from 56kbps to over 3mbps.


damn, i tried this. still running at like 30kb/s. anyone find any other ways to fix?
my cpu is usually extremely fast
Reply Quote
62 Human Death Knight
270
Posts: 1
Turn P2P off. Your upload slows down your download drastically and will bring your entire network to a stand still.


This worked, thank you.
Almost snapped on you Blizzard!
Reply Quote
Make sure to turn off peer to peer in top left under preferences.

I was downloading at 2MB/s the whole time. Only took about an hour.
Reply Quote
Posts: 1
FIX (Thanks to Xinthar):
Start > Run inetcpl.cpl > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"



Worked for me! Up at 1.2 MB/s from 70 KB/s! Thanks!
Reply Quote
FIX (Thanks to Xinthar):

Go to Control Panel > Network Connections > Internet Options > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"




Hero
Reply Quote
Posts: 1
THANK YOU XINTHAR
:)
Reply Quote
This one works perfectly, it fixed my download speed. thanks mate
Reply Quote
Posts: 1
Thanks for the fix!
Reply Quote
90 Worgen Rogue
8510
Posts: 1
Thanks Xinthar! Solved a night of frustration. And cheetos.
Reply Quote
Posts: 3
wow unchecking that thing maked my download goes from 300kb/s to 2mb/s
Reply Quote
Worked for me as well. Went from 15 kbps to max. Thank you.
Reply Quote
Posts: 1
Also worked for me oddly enough, not entirely sure why that would matter.
Reply Quote
Diito. This totally worked for me too on a Win7 system.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]