Diablo® III

Really slow Diablo III download speed

85 Worgen Druid
1815
Posts: 8
can someone direct me on how to disable the peer to peer options, because this

"Go to Control Panel > Network Connections > Internet Options > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"

does not work, i've been running as administrator and turning off my firewalls and my download speed still settles at a 55 KBS and i have a good connection and pc. my only hope is to see if taking off p2p works, other than that does anyone else have a similar problem like mine?
Reply Quote
I was wondering.... i have a 20 Mbit/s line and only get 2 directly from blizz

at the same time my girlfriend on the same LAN have the same issue... she is now gaming and the smart thinking would say that the downloader shold pull data from her...

but this is not the case... not even with p2p enabled (normal i disable it)

is that not a big BUG? ie not taking advantage of clients on same LAN ?
Reply Quote
Posts: 1
great fix, thanks!
Reply Quote
None of these fixes are working for me. Just bought a brand new computer today. Only installing 170 kb/s. Zzz...
Reply Quote
I tried to follow the uncheck "Automatically Detect Settings" but says here that local network configuration doesnt apply on dial-up conections. And i dot have any dial-up conection D:

HELP
Reply Quote
Posts: 1
FIX (Thanks to Xinthar):

Go to Control Panel > Network Connections > Internet Options > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"

OR

Start > Run inetcpl.cpl > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"


This worked for me too, but I must say myself that this is very ridiculous. Mine jumped from 0 kb/s to 1000 kb/s... Very weird.
Reply Quote
download SO Slwwooooo zzzzzz
Reply Quote
It is Monday morning and I have been downloading since Friday afternoon. I still have 11 GB left. I have a fast internet connection I have already done the speed test. What is going on?
Reply Quote
I am downloading on a Mac.
Reply Quote
The second way works for me, TY :)
Reply Quote
I tried the first and it didn't make much difference, if anything it made it slightly slower. I can't do option 2 because I'm on Windows 8.1
Reply Quote
90 Blood Elf Paladin
8570
Posts: 5
05/14/2012 11:01 AMPosted by Dinks
FIX (Thanks to Xinthar):

Go to Control Panel > Network Connections > Internet Options > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"


OR

[quote]Start > Run inetcpl.cpl > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"


Worked perfectly, went from 500b/s to 10MB/s
Reply Quote
Malaysian people says "Beres!"
Reply Quote
Thank you Xinthar :)
Reply Quote
"Dinks", that may help some people but Theres been hacker attacks against the DNS services all over europe from the 15th april. the only thing i could do that day was connect to wow and blizzards app's.. everything else was dead. sadly to say Fibia which is my ISP havent found a 100% fix yet but aleast i can get on Google and other stuff now.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]