Diablo® III

Failed to run required program (Agent)

Im glad it worked for you friend. Unfortunately it was already unchecked for me, still no luck here :(
Reply Quote
any help for a mac? there is no Agent at all in my Activity Monitor. I don't even have IE on my mac. Running Safari for a browser. I start Agent, it appears briefly in the Activity Monitor and then closes (I assume as it disappears from the Activity Monitor list.)
Reply Quote
Posts: 10
that doesnt work.. you can run the update part befoer the installation on a different computer and take C:\ProgramData\Battle.net from that pc and overwrite the faulty one on the computer your trying to install to. why doesnt blizz just put an updated version of the D3 setup rather thatn the one that needs to go through the update that wont work on many pc's.. thats just stupid on their part
Reply Quote
Posts: 10
that doesnt work.. you can run the update part befoer the installation on a different computer and take C:\ProgramData\Battle.net from that pc and overwrite the faulty one on the computer your trying to install to. why doesnt blizz just put an updated version of the D3 setup rather thatn the one that needs to go through the update that wont work on many pc's.. thats just stupid on their part
Reply Quote
I have tried everything here and still nothing.

Restarted computer
Deleted battle.net folders
turned off antivirus
... etc

NOTHING.

Blizzard, I just want to install the damn game! Why?!

Edit: I cant run as administrator.. because I cant download the game! It gets 2 seconds into it and bam, error.
Edited by Enjoi211#1501 on 5/19/2012 3:48 PM PDT
Reply Quote
This is awkward!!!!

PS, The sp2 thing is not working for me. Actually what you need to do is not only changing the Agent.exe but also the launcher. This helped a lot of other doomed ppl.
Reply Quote
I am now installed.. I wish you all the best of luck... I have done so many things to try and make this work.. some of them may have been necessary .. some of them not... and I forget what I did.. but these things do stand out in that i made progress after doing them... and may help someone out there:

First off I am running WIndows 64 bit OS.. the current up to date is SP1.. at the end of this post i will repost the last bit that eneded with me installing and playing the game:

1) Set Secondary Login service to automatic
2) Downloaded and installed
Microsoft Visual C++ 2008 Redistributable x64
Microsoft Visual C++ 2008 Redistributable x86
Microsoft Visual C++ 2010 Redistributable x64
Microsoft Visual C++ 2010 Redistributable x86
3) Manually opened ports as per the blizzard document on connectivity troubleshooting... the main one is port 80 for me.. at least cuz I had setall the other ones based on another posting
4) Checked the box on the Diablo III set up file to run as windows xp service pack 2.. i did not have the run as adminstrator box checked.. although Mu comp asks me to run it as adminstrator
5) I don't think this matters.. but for some reason I had the Agent.exe in the Agent.954 folder runnning as windows xp service pack 3

finally.. here is my previous post

OKay... here we maybe go.. I am currently at the Diablo III splash screen.. it says installing.. I am at 14% and counting.. what I did..
1) deleted all my diablo stuff.. programdata battle.net foder.. installer all that stuff
2) Downloaded and ran diablo III client from my battle.net account.. ya know where yo utell them your birthday b4 you can download it.
3) Ran the client till it pooped
4) Now here is where I went tricky.... earlier in this epic I found this site
http://www.gamefront.com/files/21699449
and downloaded the zip file he puts up there.
5) Unzip the files and replace the C:\programdata\battle.net folder with the zipped files
6) Run the client you downloaded from battle.net
Reply Quote
Alt and F doesnt work :(
Reply Quote
I am installing!!!!!!!!!!!

May be blizzard has fixed the issue, may be my computer just love me again. I ain't do anything about it, just repeat the deleting the battle.net and try the install launcher, and bam, it works.

Good luck to all of you!!!!!

I'm going to enjoy my Barbarian!!!
Reply Quote
anyone have a fix yet?i actually got a nice response from a blizzard employee and tried what they recommended but still nothing.i just want to play!!
Reply Quote
Nope. Tried everything mentioned in the 12 pages of this thread. Nada. Cannot even install the game, much less run it and play.

Still getting "Failed to run a required program (Agent)." I am seeing multiple Agent.exe*32 processes running, but none of them seem to respond to the setup program.

Or if I am really lucky, "Cannot write to your hard drive"; even though there are multiple HDD's, and all of them have at least 25 GB free.

This is pathetic. I feel like the launcher was written for DOS or something.

Windows 7 ultimate x64 + all the latest SP's and stuff. US English locale. 10+ hours of fiddling with this FUBAR agent system that SUCKS. I think I have had enough.

--KAT.
Reply Quote
@Kat

Did you happen to run through the steps I posted? I know every comp is different... but I think the last piexe that really put me through to the other side was the compatibility deal of run as Windows XP, sp2... I know as I went through this looong road I would add things I read in the forums.. and I would get farther and farther.. but mainly it was the battle.net files I downloaded from that external link.. it had a Agent.954 folder.. anyway Good luck Kat!
Reply Quote
@Kat

Did you happen to run through the steps I posted? I know every comp is different... but I think the last piexe that really put me through to the other side was the compatibility deal of run as Windows XP, sp2... I know as I went through this looong road I would add things I read in the forums.. and I would get farther and farther.. but mainly it was the battle.net files I downloaded from that external link.. it had a Agent.954 folder.. anyway Good luck Kat!


Yup yup... followed all your advice... the issue is that the agent runs multiple processes, and the setup never seems to find them. However, if I force the agent manually, and by some miracle it *tries* to connect, I get the dreaded HDD failure message.... *GRRRRRR*

Trying 1 last time now... let us see what happens.

Thanks for the encouragement, though! ^_^

--KAT.
Reply Quote
i have google chrome ive looked at all the forums an nothing works
Reply Quote
Internet run in offline mode - diabled
Enable secondary logon service
Delete Battle.net application data
Turn off firewall temporarily
Turn off security essentials temporarily
Remove any compatibility modes

:) worked for me
Reply Quote
Tausken,

Start with deleting the C:\ProgramData\Battle.net folder and restarting the installer. That will force it to reacquire the setup files which may be all it needs.

____________________________________________________________________
Support Information Administrator
bull
Reply Quote
Tried for 12 hours straight to fix this, tried all suggestions and still no joy. Was having problems bringing up task manager and regedit too so got this software, ran it, it fixed task manager and regedit, then tried to install diablo 3 and worked straight away, hope this helps.
http://www.sergiwa.com/modules/mydownloads/singlefile.php?cid=2&lid=1
Reply Quote
How to fix it. could give more detail?
Reply Quote
85 Tauren Druid
9910
Posts: 66
I see that the last post in this forum was a few days ago, is there a known fix for this issue now? I started to get the error over 2 days ago and have tried everything suggested in this thread and sent a ticket in over 48 hours ago with no response. Don't know if the patch is supposed to fix this because I can't patch...
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]