Diablo® III

Failed to run required program (Agent)

disable peer-to peer
and hope u have at least 1mbps line or u are screwed
Edited by Locust#1688 on 8/10/2012 5:35 AM PDT
Reply Quote
its programdata/battle.net
click on start - search - battle.net
u can see where it is
Reply Quote
Ok when i did what you said it keep on saying there a patch to download want to download
Reply Quote
I just got this problem for the first time. I was able to end all agent.exe processes and delete my battle.net folder from /programdata, and the start the launcher. It workes perfectly now.
Reply Quote
05/11/2012 08:55 PMPosted by Barthus
Strangely enough, I've never seen anyone reporting this before and it's been quite some time since I ran the launcher with 'Work offline' mode enabled to see if the agent was able to take IE out of 'Work offline' mode or not.


Thanks, helped me out
Reply Quote
31 Gnome Mage
445
I fixed the problem do this
step 1: go to C:\ProgramData\Battle.net when it is open click on agent
step 2: copy the data base file called agent
step 3: past it in the wow folder on the hard drive where you have installed it at

Happy Playing and have fun
Finding his
Reply Quote
90 Human Paladin
2770
Omg thanks so much! You guys rock!
Reply Quote
90 Human Paladin
2770
Omg you saved me! Thanks so much! I can play MoP now!! Yaaay!! WOW ROCKS
Reply Quote
Nothing of what you did worked for me, Figured it out by myself.

ProgramData > Battle.net > Agent, and try every Agent..

I didnt have the problem with diablo tho, i had the problem with the WoW Patch today, thanks for some helpful advices tho!
Reply Quote
It didnt fix the problem anyhow, just got me stuck on 65%
Reply Quote
41 Night Elf Druid
1440
C:\ProgramData\Battle.net my computer is taking forever to find this. What do I do?
Reply Quote
90 Worgen Warrior
9205
I went to C/ battle.net agent after running the updater, and right clicked on the agent and ran as administrator...worked fine
Reply Quote
90 Worgen Warrior
9205
to find the folder, go to your C drive and search battle.net
select on the one that says Battle.net in C://program data
Reply Quote
If you haven't tried unchecking work offline in WE, give it a shot. I haven't used WE in over a year. In desperation, I opened it up on the random chance that it could work, found working offline was checked, unchecked it and "Abracadabra"....the launcher works again.

I saw this suggestion in another thread. I thank those that continued it on, it worked for me.
Reply Quote
1 Worgen Warrior
0
nothing is working for me same issue, there is nothing called battle.net on my computer... only thing I can find is in WOW folder battle something.dll

It worked fine yesterday now nothing.......
Reply Quote
Ok if everyone is having this problem do what BARTHUS said because ti worked like a charm for me
Reply Quote
90 Blood Elf Warlock
5815
* Crtl+Alt+Del
* Delete all argent.exe
* Start to download the game again
Reply Quote
77 Human Priest
3365
For any future readers, the best thing to do is go to your appdata, delete ALL blizzaard and battle.net folders that may exist.
Reply Quote
in tast manager appears 3 open agents but install is not working, it worked perfect since 5 days, no i cannot play due to this stupid agent..whay can i do a format install of windows will help?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]