Diablo® III

Failed to run required program (Agent)

59 Undead Death Knight
9320
If you see multiple Agent.exe processes it means the Setup is able to start the Agent but gets no response when querying the Agent. Something is blocking them.

meh. page two. Anyone who didnt read page one should try this before anything else:
http://us.battle.net/d3/en/forum/topic/4926862691?page=1#11

And have you tried deleting the Battle.net folder in C:\ProgramData\
Edited by e1D#1473 on 5/14/2012 1:07 PM PDT
Reply Quote
90 Blood Elf Mage
9965
05/14/2012 12:41 PMPosted by Barthus
Before you get the error, did you check if multiple Agent.exe processes were being started or you see no agent.exe processes at all?


I have watched task manager and there is no more than one at one time however it seems like it is running but the launcher is not responding with it... I sat there and hit end process every time it popped up and it did not change anything.
Reply Quote
85 Tauren Druid
1020
Wish I could get multiple agent.exe's, still cant find a way to get agent.exe to run in windows 7 x64
Reply Quote
Ok ive finally got it to work, I ended the process while installing, I must have missed that.
Reply Quote
59 Undead Death Knight
9320
Does the Agent run if you type this on a CMD window:
"C:\ProgramData\Battle.net\Agent\Agent.954\Agent.exe" --show --autoclosedelay=30
The above path is for Windows 7, 8 or Vista.
Edited by e1D#1473 on 5/14/2012 1:06 PM PDT
Reply Quote
85 Tauren Druid
1020
I had my buddy send me his agent folder, and I furiously spammed all the copies of agent I had during the d3 updater (im getting desperate)

it eventually patched over his agent, then hung at updating, then gave me the same failed to run a required program AGENT i've been getting for a month
Reply Quote
85 Tauren Druid
1020
My buddy sent me his agent 954, Barthus

my blizzard updater installs agent 524 on my computer

gonna try your command here in a sec

edit: Nothing happens Barthus. It just goes to the next line and nothing runs.
Edited by Coraz#1148 on 5/14/2012 1:13 PM PDT
Reply Quote
This worked for me.

Thanks for the help!
Reply Quote
59 Undead Death Knight
9320
I had my buddy send me his agent folder, and I furiously spammed all the copies of agent I had during the d3 updater (im getting desperate)

it eventually patched over his agent, then hung at updating, then gave me the same failed to run a required program AGENT i've been getting for a month

During the Beta, the failed to run agent most of the time was being caused when an old version of the setup was trying to start a newer version of the Agent. But that shouldn't happen now.
Reply Quote
90 Blood Elf Mage
9965
Does the Agent run if you type this on a CMD window:
"C:\ProgramData\Battle.net\Agent\Agent.954\Agent.exe" --show --autoclosedelay=30
The above path is for Windows 7, 8 or Vista.


it ran for maybe 45 seconds saying something about doing a flush and then it closed. Was that what was supposed to happen?
Reply Quote
85 Tauren Druid
1020
I have a totally different problem from everyone else it seems.. Agent wont run no matter what I do. I've never seen agent.exe on the task manager trying 100 different ways to launch any and all versions of Agent.exe
Reply Quote
59 Undead Death Knight
9320
Does the Agent run if you type this on a CMD window:
"C:\ProgramData\Battle.net\Agent\Agent.954\Agent.exe" --show --autoclosedelay=30
The above path is for Windows 7, 8 or Vista.


it ran for maybe 45 seconds saying something about doing a flush and then it closed. Was that what was supposed to happen?

Do that then run the setup and see - on the cmd window - if it's receiving any queries from the setup.
Edited by e1D#1473 on 5/14/2012 1:18 PM PDT
Reply Quote
59 Undead Death Knight
9320
05/14/2012 01:15 PMPosted by Corazx
I have a totally different problem from everyone else it seems.. Agent wont run no matter what I do. I've never seen agent.exe on the task manager trying 100 different ways to launch any and all versions of Agent.exe

That's pretty weird. You should check for malwares, remove applications that could be interferinfg with the agent, etc.
Reply Quote
85 Tauren Druid
1020
my last option is to format and reinstall windows 7

which may not solve anything and waste my entire day before work

unless i have some crazy virus that I'm unable to detect, I don't get why this is the only exe in my entire life that I couldn't run by double clicking
Edited by Coraz#1148 on 5/14/2012 1:21 PM PDT
Reply Quote
90 Blood Elf Mage
9965
okay after doing that Bar I was noticing more than one Agent.exe and it actually took me to the launcher interface. However I just received a " a communication error occurred, please restart. The problem persists contact customer support."

this is really annoying :(
Reply Quote
59 Undead Death Knight
9320
Something is disrupting the communication between the Setup > Agent and Launcher > Agent. I have no idea what could ne causing this.
Reply Quote
59 Undead Death Knight
9320
my last option is to format and reinstall windows 7

which may not solve anything and waste my entire day before work

unless i have some crazy virus that I'm unable to detect, I don't get why this is the only exe in my entire life that I couldn't run by double clicking

Do you get any error at all when you try to open Agent.exe directly with that command?
Reply Quote
85 Tauren Druid
1020
No; nothing happens, as if I did nothing. I've never had a program just do nothing before. No cmd window popup, no agent.exe in the process list (even for a split second)

It just doesn't run.
Reply Quote
85 Tauren Paladin
UE
0
Did What Barthus said and also deleted my battle.net folder, I got it to start installing! Thanks! Was getting frustrated because it installed on my laptop with no problems, but on my desktop (which had the beta installed) it was being an issue.
Reply Quote
90 Human Warrior
10500
Im having the same problem on my other laptop, Mine downloaded just fine but when I try to install the setup I get a error missing agent prompt and the updates dont work. I tried typing in what Bar said in the CMD prompt and this is what i got

Argument[0]: 'C:\ProgramData\Battle.net\Agent\Agent.954\Agent.exe'
Argument[1]: '--show'
Argument[2]: '--autoclosedelay=30'
Database Insert: /option
Database Insert: /agent
Database Insert: /
Database Insert: /version
Database Insert: /repair
Database Insert: /update
Database Insert: /install
Database Insert: /gamesession
Database Insert: /backfill
Database Insert: /game
Database Insert: /game/diablo3_beta_enus
Database Insert: /game/client
Database Insert: /spawned
Database Insert: /agent/download
Database Insert: /register
Initialize HttpProtocol Server Called.
Agent started on port #1120
Executing operation: disable_firewall applicationPath="C:\ProgramData\Battle.net
\Agent\Agent.954\Agent.exe" applicationName="Blizzard Agent"
Agent successfully added a firewall exception for 'C:\ProgramData\Battle.net\Age
nt\Agent.954\Agent.exe'.
Registered Periodic Event: "auth validation event" with a resolution of 10000 an
d a start delay of 30000
Registered Event: "shutdown event"
Registered Event: "database flush event"
Handle Event: "auth validation event"
Registered Periodic Event: "shutdown event" with a resolution of 10000 and a sta
rt delay of 0
Handle Event: "shutdown event"
Handle Event: "auth validation event"
Agent is shutting down
Database Remove: /option
Database Remove: /agent
Database Remove: /agent/download
Queue 'default' Resource for delete
Database Remove: /
Database Remove: /register
Queue 'registerroot' Resource for delete
Database Remove: /game
Database Remove: /game/client
Queue 'game' Resource for delete
Database Remove: /game/diablo3_beta_enus
Deferred delete of 'default' Resource
Deferred delete of 'registerroot' Resource
Deferred delete of 'game' Resource
Deferred delete of 'game' Resource
Queue 'game' Resource for delete
Queue 'gameroot' Resource for delete
Database Remove: /repair
Queue 'repairroot' Resource for delete
Queue 'agentroot' Resource for delete
Database Remove: /gamesession
Deferred delete of 'gameroot' Resource
Deferred delete of 'repairroot' Resource
Deferred delete of 'agentroot' Resource
Queue 'gamesessionroot' Resource for delete
Database Remove: /backfill
Queue 'backfillroot' Resource for delete
Database Remove: /spawned
Queue 'spawnedroot' Resource for delete
Queue 'optionroot' Resource for delete
Database Remove: /version
Queue 'versionroot' Resource for delete
Database Remove: /update
Queue 'updateroot' Resource for delete
Firing Event: "database flush event"
Deferred delete of 'gamesessionroot' Resource
Deferred delete of 'backfillroot' Resource
Deferred delete of 'spawnedroot' Resource
Deferred delete of 'optionroot' Resource
Deferred delete of 'versionroot' Resource
Deferred delete of 'updateroot' Resource
Database Remove: /install
Queue 'installroot' Resource for delete
Queue 'root' Resource for delete
Deleting remaining resources
Deferred delete of 'installroot' Resource
Deferred delete of 'root' Resource
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]