Diablo® III

Failed to run required program (Agent)

ive tried everything..the only thing i cant seem to understand is when its in the updating files window theres supposed to b a agent.exe running in task manager nd i dont see any agent.exe running.blizzard needs to fix this...this is bull#$@!
Reply Quote
So is there anything I can do to fix this?? I have done everything that was said in this tread, nothing worked. I have had all sorts of stupid problems since I got the game. I have downloaded the client 4 times, done tons of different things to fix a huge amount of issues.

Now I am stuck on this "failed to run a required program(Agent)". Tried all tips, nothing works.

I have annual pass and I expect Blizzard to give me this game without a huge amount of hassle. This is starting to turn into a huge damn joke from Blizzard. I just want to install the game and play it, but no, I need to read up pages upon pages to fix errors after errors.

Trying to get hold of Blizzard is also to hard right now.

I am so damn close to just call Blizzard and end Annual pass and try to demand back money from months of wow. I sure as hell would not sign up for Annual pass when I cant get D3 working.
Reply Quote
lol after my little nerdrage here it finally worked out! Found one last thing I could do. I got the d3launcherfix.

Here is some info:

D3 Launcher Fix - By Nyleveia.com

Navigate to C:\ProgramData\Battle.net\Agent and delete both Agent.exe and your Agent.xxx folder.
Extract the contents of the ZIP to C:\ProgramData\Battle.net\Agent
Re-run the original setup executable (Diablo III Beta enXX Setup.exe - XX being region of setup file)

Installer will hang where it usually does, but only for a short while, it's downloading and installing the client now.
Launcher will correctly load shortly.

Enjoy!, if you found this helpful, head over to Nyleveia.com and let us know!
Reply Quote
AGAIN! now it wont install... comes up "an unexpected decryption error occured" when pressing install.
Reply Quote
24+ hours later, still cant get it to do anything
Reply Quote
oh yeah, opened a support ticket they told me to restart my computer and try again, that was 16 hours ago, havent heard back after replying to that message
Reply Quote
not sure why, but i decided to try to download the enGB file instead of the US one, and its working, so far.
Edited by Tonkar#1322 on 5/16/2012 5:33 AM PDT
Reply Quote
didnt think it would be this dang hard to play a freaking game
Reply Quote
Is there any other posibility to download the game? Because i cannot download my game using downloader, because of peer-to-peer way of downloading.
Reply Quote
05/16/2012 06:22 AMPosted by Justinianas
Is there any other posibility to download the game? Because i cannot download my game using downloader, because of peer-to-peer way of downloading.


You can goto:
http://www.reddit.com/r/Diablo/comments/r37gr/d3_digital_predownload_bypassing_the_downloader/

I still had to use the following to get it to start installing:

I've uploaded my working Battle.net files to see if it may help anyone. Feel free to test and let me know.

http://www.gamefront.com/files/21699449/D3+-+Battle.net+Files.zip

Place them inside: C:\ProgramData\Battle.net

Agent
Client
Setup


Now my issue is this:

Anyway, I've since uninstalled, re-downloaded, and reinstalled diablo 3 and am back at the same point, but no blzpts00007 error anymore. Now when I run the launcher, it updates about 14000+ files in the first step [red], then updates about 600 files in the second step [yellow], and then it turns green and says its up to date. At some point during the second step or the up-to-date step at the end, the agent crashes and it says Battle.net update agent has stopped working. Then the whole thing starts again and just keeps cycling over and over.

If I press 'play' when it becomes available, it just hangs there on "launching" forever.

I'm still scouring the forums for a solution that works. I'm running vista 32 bit but i do meet all the system requirements and have unsuccessfully tried almost every solution I've seen out here other than reformatting (I won't go that far).


This stuff has worked for some people though. Hope you're one of them.
Reply Quote
still no progress here

tried everyones fixes
nada

Win 7 home premium
no agent even showing up in task manager
can't seem get another blizzard downloader, but when i go to the battle.net download client it runs the diablo setup and if i delete the battle.net folder before-hand i get to the N in updating

blues, please give us some direction
Reply Quote
Last question before begin of my suffering : does it work for eu kind of player, like me ?
Reply Quote
This is the error I keep getting when I'm trying to install the game.
http://tinypic.com/r/rubadk/6
Edited by Jeff#1661 on 5/16/2012 7:02 AM PDT
Reply Quote
That was my problem, I executed the shortcut Diablo III as administrator and its work fine for me. There was the same problem with the beta.
Edited by m939#1521 on 5/16/2012 7:19 AM PDT
Reply Quote
Posts: 11
Thanks for this guide I remove the C:Programdata\battlenet folder and try again without restarting and now I'm on the installation process already 43%....

I hope I don't get disconnected or something.

BTW I previously installed an Open beta but didn't finish and got some error.. I think this is the cause of the agent.exe error. tsk tsk
Reply Quote
1) Delete C:\Programdata\Battle.net
2) Run diablo III's launcher, wait for the patch to fail due to the agent.exe error
3) Run C:\Programdata\Battle.net\Agent\agent.exe
4) Run C:\Programdata\Battle.net\Agent\Agent.524\agent.exe
5) Run diablo III's launcher, wait for the patch to complete (~3 minutes or so)
6) Run the game.


Is everyone has that file because i'm a 7 years old wow player and still can't find it....Also i had no trouble like this yesterday but i needed to format my computer and all data was gone something went wrong somewhere and now i'm having this problem too...
Reply Quote
Posts: 6
Nearly 24 hours and Blizzard STILL hasn't managed to pull their heads out of their asses and fix this? I don't even understand what they could have done with this program that it runs the possibility of being entirely incompatible with WINDOWS of all things. Macintosh runs just fine, but heaven forbid that they take care of their primary audience's issues with this game. Ugh, /endrant.

Seriously though, I've spent literally the last day sifting through forums and trying everything I see, and I've yet to arrive that the installation screen. I'm seriously about to just reformat my whole bloody system and see what happens. Hell, the only reason I haven't yet is because the pessimist in me keeps telling me that it won't do any good :\

What ever happened to the good old days when a game had it's own bloody installation setup, and everything was peachy? Hell, Age of Empires 3 was the easiest damned game to install that I've had to deal with since the original Starcraft. Ugh, I think I'll go play a game or two just to blow off some steam >.>
Reply Quote
Posts: 30
Cant even get past the Diablo 3 Setup Failed to run a required program agent. Tried all of these fixes and nothing still.
I'm so sad
Reply Quote
Posts: 8
Sigh... Me too
Reply Quote
Posts: 8
http://patchup.info/d3/tfil/NA/

This patch site gave me an idea. Im in the US and I've tried to Download the digital version and have run into the same problems as most here with the Agent errors. I saw a post on this forum about this patch info site. Checked it out and found in the bottem there were options for different downloads for different countries. I clicked on the US version and had the same problem however when i chose the gbEN option the downloader is working. I dont know if the game will work or if they'll be serving fish and chips instead of hamburgers, however I'll let you know what happens!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]