Diablo® III

Failed to run required program (Agent)

can you quide me a bit further where AUTODIALERS button is in internet options cant seem to find it?
Reply Quote
go to your connections tab in your internet options and select the never dial a connection option
Reply Quote
i did that... but i dont have image file execution options folder in my registry editor.?
Reply Quote
ohh wait sorry i found it but no Agent.exe in there :S ? thanks for the help so far.
Reply Quote
Bump for issue still not resolved. Have opened 3 tickets so far, first one was answered with a worthless link to help pages we've all already tried, the second had a response telling me to make sure my windows had all microsoft updates (it does), but the followup answer was yet another link to the worthless links. This is beyond pathetic, we're completely hung out to dry.
Reply Quote
1 Human Mage
0
Posts: 8
OK OK I GOT IT... I HAVE FIXED THIS EXACT PROBLEM AFTER DAYS OF WORK... IT IS A COMBINATION OF THINGS

DELETE THE GAME AND ALL BATTLE>NET FOLDERS...

GO TO INTERNET OPTIONS AND TURN OFF YOUR AUTODIALERS

THEN DO THE FOLLOWING AS KILLPRAY SAID

''I had "Failed to run a required program (agent)" appears with the error code "BLZPTS00007" I Had tryed all the methods that were give but i found one that helped. I fixed the Agent.exe problem and got the game to install by going into my registy

EVERYON DO THIS IT HELP ME HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Excution and deleting Agent.exe. ''






#140



39 minutes ago
Reply Quote
Same problem here, oddly enough I was in the beta just a couple weeks ago when they had their free stress-test. No problems installing then....

I've also tried all these "solutions" and none of them work.

There is no reason an IE setting should effect blizzards own client. This is piss poor programming, either they use the agent.exe as a shell or they don't know how to write their own code to allow downloads/updates/etc. Both of which should be resolved LONG before a retail launch.

*edit
Now it's working, no idea how or why as I've restarted and deleted the battle.net folder a dozen times. Only difference this time is that I powered down my laptop completely out of frustration before giving it one more go...

**edit edit
Now the installer is giving me an error about not being able to read "a required file" no mention of what file or any error code this time. Just a suggestion to disable all antivirus software and close every open program. Also the launcher seems to hang after every failure.

Currently I am having to shut down, wait 30 seconds, boot windows, launch the shiny new D3 icon, watch as it does the update check and hope agent.exe doesn't !@#$ itself again then it starts to download for an indeterminate time then giving me the above error.
Edited by Coyote#1838 on 5/16/2012 5:20 PM PDT
Reply Quote
OK OK I GOT IT... I HAVE FIXED THIS EXACT PROBLEM AFTER DAYS OF WORK... IT IS A COMBINATION OF THINGS

DELETE THE GAME AND ALL BATTLE>NET FOLDERS...

GO TO INTERNET OPTIONS AND TURN OFF YOUR AUTODIALERS

THEN DO THE FOLLOWING AS KILLPRAY SAID

''I had "Failed to run a required program (agent)" appears with the error code "BLZPTS00007" I Had tryed all the methods that were give but i found one that helped. I fixed the Agent.exe problem and got the game to install by going into my registy

EVERYON DO THIS IT HELP ME HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Excution and deleting Agent.exe. ''






#140



39 minutes ago


I am sure Blizzard skims through the threads and reads these posts thinking their work is done.

THIS HAS NOT HELPED A LARGE GROUP OF PEOPLE. WE DON'T HAVE A "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Excution Option\AGENT.EXE" OR VIRUS ON OUR PC's PREVENTING AGENT.EXE FROM RUNNING.
Edited by Qwellious#1713 on 5/16/2012 5:00 PM PDT
Reply Quote
I was having this problem when i tried loading D3 about 10 minutes ago, i closed the updater, went to the battle.net folder and ran the agent.exe file, then loaded the game and it worked.
Reply Quote
Posts: 10
I have tried all of the above plus trying to install after starting up without background processes and also trying in safe mode with networking. Still no luck. It gets so far and then during the install just after it makes the diablo III.temp folder into the diablo III folder the agent fails and the install starts over with continuous agent crashes. I am on Win XP.
Reply Quote
its strange when i run it as JEshu says it stays at 0% checking for updates forever. but if i delete the battle.net folder and install agian it goes to 30-40% and it makes opdating file setup.. hmm :)
Reply Quote
Posts: 5
This error is happening to me but I found a work around: Run the CD Installer's exe. This, somehow, ran the Agent.exe properly.

I'm gonna try the registry fix later.
Reply Quote
Posts: 6
Is there any way to get some of the blizzard staff fired or something over this? I mean seriously, if I were a vehicle manufacturer I'd get in some serious !@#$ if some of my cars didn't quite turn on after you bought them. If I were a gunsmith I'd probably lose my %^-*ing job if someone brought me a gun, asked me to fix it, and instead I just removed the broken part and tossed it back at the customer. I'd think that a software programmer would get into the tiniest bit of trouble if they developed a program that refused to run!

I thought the whole point of being able to fire someone was so help ensure they didn't half !@# their work and $%^- over the company >.>

Ugh, anyways, has there been any kind of acknowledgement of this issue? I mean it seems fairly obvious to me, a regular *!@ person with basic information gathering skills, that a fair number of paying customers are dealing with this issue, and so far the only people I've seen trying to deal with this problem are the customers themselves! Hell, what happened to that blizz rep from the beginning of this thread? >.<
Reply Quote
Is there any way to get some of the blizzard staff fired or something over this? I mean seriously, if I were a vehicle manufacturer I'd get in some serious !@#$ if some of my cars didn't quite turn on after you bought them. If I were a gunsmith I'd probably lose my %^-*ing job if someone brought me a gun, asked me to fix it, and instead I just removed the broken part and tossed it back at the customer. I'd think that a software programmer would get into the tiniest bit of trouble if they developed a program that refused to run!

I thought the whole point of being able to fire someone was so help ensure they didn't half !@# their work and $%^- over the company >.>

Ugh, anyways, has there been any kind of acknowledgement of this issue? I mean it seems fairly obvious to me, a regular *!@ person with basic information gathering skills, that a fair number of paying customers are dealing with this issue, and so far the only people I've seen trying to deal with this problem are the customers themselves! Hell, what happened to that blizz rep from the beginning of this thread? >.<


I agree completely. I have literally worked on this stupid INSTALLER UPDATER problem for DAYS...since the beta. I couldn't play the beta (submitted ticket), and thought they would at least iron out the problem during release.
Reply Quote
agreed.im like almost ready to give up nd get my money back
Reply Quote
Same problem here, oddly enough I was in the beta just a couple weeks ago when they had their free stress-test. No problems installing then....

I've also tried all these "solutions" and none of them work.

There is no reason an IE setting should effect blizzards own client. This is piss poor programming, either they use the agent.exe as a shell or they don't know how to write their own code to allow downloads/updates/etc. Both of which should be resolved LONG before a retail launch.

*edit
Now it's working, no idea how or why as I've restarted and deleted the battle.net folder a dozen times. Only difference this time is that I powered down my laptop completely out of frustration before giving it one more go...

**edit edit
Now the installer is giving me an error about not being able to read "a required file" no mention of what file or any error code this time. Just a suggestion to disable all antivirus software and close every open program. Also the launcher seems to hang after every failure.

Currently I am having to shut down, wait 30 seconds, boot windows, launch the shiny new D3 icon, watch as it does the update check and hope agent.exe doesn't !@#$ itself again then it starts to download for an indeterminate time then giving me the above error.


NO KIDDING! I am blown away that I couldn't download the game because fking IE was in 'work offline' mode. Are you kidding me? They've been working on this game for over 10 years and they can't even get the download agent right? Makes me nervous about the game proper. This has definitely left a bad taste in my mouth and I hope Blizzard makes it up to the community somehow.

I hope all you gents get things working sooner than later!
Reply Quote
I couldn't find any posts with a similar issue so I created this. I understand that your unable to install, but I wanted to make sure the update thing worked at least.
When I run Diablo 3's setup after download it does the whole "Checking for updates" and it gets about halfway across when an error "Failed to run a required program (agent)" appears with the error code "BLZPTS00007"


1. Go to: start menu
2. in search, type: regedit
3. find: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution
4. in the Image File Execution folder, look for agent.exe
5. If you find it, rename it. I just renamed it to agent2.exe
6. close out of everything
7. run diablo 3
Reply Quote
Posts: 5
I am also having these problems with installing Diablo 3. I have tried everything like they say with no results but i just came across something interesting that maybe someone could put into some sort of solution. I just tried manually running the Agent application while having the setup.exe already doing its thing and i got this message spammed in the Agent.exe window

Request Issued: GET /update/client
Response:200
{
"state" : 1000.000000
}

It goes on and on for eternity while the progress bar stays at around 65%. I have also noticed that if i close the Agent.exe the "Updating setup files..." message changes to "Launching Blizzard Launcher..." and from there it stays for a minute or so then starts the Agent.exe on its own and around we go.

I would have to agree that this Agent application is definitely the problem I think but I'm no computer guy.
Reply Quote
05/16/2012 02:07 PMPosted by JoePasta
So I downloaded all 7.60gb of the program through the euro GB version but i got the same error at the end of it. I'm giving up for the time being, being as ive spent the greater part of this day attempting to reach a solution. Good Luck all


same thing
Reply Quote
I couldn't find any posts with a similar issue so I created this. I understand that your unable to install, but I wanted to make sure the update thing worked at least.

When I run Diablo 3's setup after download it does the whole "Checking for updates" and it gets about halfway across when an error "Failed to run a required program (agent)" appears with the error code "BLZPTS00007"


1. Go to: start menu
2. in search, type: regedit
3. find: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution
4. in the Image File Execution folder, look for agent.exe
5. If you find it, rename it. I just renamed it to agent2.exe
6. close out of everything
7. run diablo 3


ok got to step 4, there is no agent.exe in that folder, now what
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]