Diablo® III

Mouse Lag

90 Blood Elf Paladin
16100
I was curious if anyone else was experiencing any lag when it came down to their mouse on the log in screen. I have my settings on the lower side, and when I drag my mouse across the screen, the buttons and commands highlight nearly a second later.
Reply Quote
It might be due to high resolutions and FPS being low?

Do you have any other game to test with that can push graphics?
Reply Quote
90 Blood Elf Paladin
16100
It might be due to high resolutions and FPS being low?

Do you have any other game to test with that can push graphics?


Sadly, no. WoW is the most graphic intense game I own at the moment. Yes I know it isn't very graphical, but I can atleast run it on higher settings with 50-80 fps and 0 mouse lag.
Reply Quote
Turn on VSync (it's in the game options) if it isn't already. There was another user who reported this, and vsync fixed it for them.
Edited by VincentLaw#1115 on 5/14/2012 5:25 PM PDT
Reply Quote
90 Blood Elf Paladin
16100
05/14/2012 05:25 PMPosted by VincentLaw
Turn on VSync (it's in the game options) if it isn't already. There was another user who reported this, and vsync fixed it for them.


Tried to turn it on. Still noticed the same amount of lag when it came down to highlighting the buttons. Oh well, I'll just hope that things are different in game.
Reply Quote
Sadly I am in the same boat and it is pretty frustrating. I've tried turning on and off various settings like vsync, anti-aliasing, even putting all of my settings to "Low", with no luck. I am unsure of a fix :(.
Reply Quote
90 Blood Elf Paladin
16100
05/14/2012 05:53 PMPosted by Windz
Sadly I am in the same boat and it is pretty frustrating. I've tried turning on and off various settings like vsync, anti-aliasing, even putting all of my settings to "Low", with no luck. I am unsure of a fix :(.


Hopefully it's just the menu, and the gameplay is unaffected.
Reply Quote
Try running the game in Windowed mode. That will make the mouse behavior different.
Reply Quote
Tried that, didn't help. My computer is under a year old as well, and is considered a "high settings" comp. :(
Reply Quote
I'm having this same issue, and I noticed the background halts as well, not just the curser. Look at the smoke and birds, are they getting 'stuck' also?
Reply Quote
I'm having the same issue in the actual game
Reply Quote
bump for a similar issue. Can we get a blizz response at least clarifying if they are working on a fix or not...or if they are just aware, period.
Reply Quote
bump, same issue, i just bought a new graphics card and i now meet all the recommended system requirements easily. So I'm not sure what could be the cause, have all drivers up to date as well.
Reply Quote
*update* keyboard lag as well when typing password/ username to login to D3
Reply Quote
I am too having a issue like this, but it seems as if mine is more extreme, I had spent 5 hours of installing and trying to figure out all this crap with errors... finally got onto the game a hour ago... didnt even get to play. its impossible. my mouse was bad on the log in screen too but i figured it would get better.. I attempted to play in game but that failed. i check my ms, it is 201.. my connection is fine.. i dont know what else could be causing this??? I meet the requirements for everything too... except the video card. but still it should work!!! someone help
Reply Quote
ASUS g75V i7-3610QM 16GB RAM nvidia GTX650M
Same issue with the synaptics trackpad.
Reply Quote
75 Night Elf Hunter
2220
I am having the same mouse lagging problem. The mouse works in other programs like WoW and on the desktop, but I can barely play and get constantly killed because I cannot respond to monsters. Per suggestions, I have set to windowed, vsync on, text set to smaller, and none of it has made any difference. I am running Windows 7 and a Logitech mouse. Has Blizzard addressed this at all? Any more suggestions out there?
Reply Quote
Windows 7 64 bit
Using a supported GeForce
Random crappy wired HP USB mouse

Problem started 3-4 days ago. I've searched plenty of Windows 7 forums and tried some of the noted fixes to no avail.
Reply Quote
Bump,
same problem I am running Ultra on all settings problem showed up a few days ago
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]