Diablo® III

"Failed to read a required file" error

90 Pandaren Rogue
6655
Posts: 36
Trying to install the game after pre-downloading the client and kept getting a msg saying "Failed to read a required file". So stupid me after getting this msg several times decided to delete the Diablo file and re-download it. Now I'm getting the same message again. Anyone else? Really frustrated with this.
Reply Quote
85 Human Paladin
8885
Posts: 2
I got this too!! BLAH!
Reply Quote
Posts: 4
same!
Reply Quote
100 Orc Hunter
7270
Posts: 53
ctrl+alt+del and close Agent... try again.

Worked for me.

edit: now its updating files 6000/14474 - play button grey atm.
I think everything is ok now...
Edited by Vathriz#1320 on 5/14/2012 10:50 AM PDT
Reply Quote
90 Pandaren Rogue
6655
Posts: 36
Hasnt worked for me. I cant even pre-download the client now. Still says "Failed to read a required file". THIS SUCKS.
Reply Quote
Posts: 6
Lovac,

Worked like a charm thanks.
Reply Quote
Kill agent process and everything, close launcher

go to c:\program data\battle.net\agent.954 and run agent.exe

after that start the launcher, if it freezes again kill agent.exe again while the launcher is opened.

the agent.exe process should start again automatically and it should work
Reply Quote
been there, here is how it worked for me

I updated my Nvidia driver, i installed frigin IE9 (I am a chrome user) and I restarted the PC.

then launched the launcher file worked, started checking and resumed downloading, not sure if it will work but till now though it say Playable the game itself wont launch hoping it will do after completing the optimal phase
Reply Quote
Thanks Lovac, killing the agent did the trick.
Reply Quote
Okay, This worked so easy. I didnt have to delete ANYTHING. For me, that is not the problem. Its taken me atleast 2 hours to go through ALL these different fixes. But, none worked. So what I did, I went into my "administrator" account. I logged off my current account, then switched to my administrator account. (for windows 7, youtube how to make admin account) then just ran diablo that way. IT WORKED! :D but, DO NOT RIGHT CLIK PROGRAM AND CLICK "run as admin" It doesnt work. Atleast not for me.(:
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]