Diablo® III

Finished the client, sitting at 0% install

So I downloaded the client flawlessly, ran it again over what I just downloaded to make sure I had everything. When the Installer pops up, I hit Already activated D3, then a window pops up saying, "Diablo III requires a newer operating system to run." I hit Okay then, "I've already activated." NOW.. it sits at 0% and Installing... and I've let it run for 10 minutes already, and still no progress.. what the heck?
Reply Quote
I've read that for Vista you require Service Pack 2. What OS are you using?
Reply Quote
Sorry, I am running Windows 7 Service Pack 1
Reply Quote
I am having the same problems! >:[
Reply Quote
I just don't get it. Before when I was getting the Error 108 I made it to about 31% but now that I have all the correct files I'm stuck at 0% lol...
Reply Quote
Support Forum Agent
Valefor

Lets try this to see if it helps with your issue:

1. Make sure that your system is showing hidden files.

Here's a link that will help with that: http://windows.microsoft.com/en-US/windows-vista/Show-hidden-files

2. Navigate to the C drive > Program Data folder.
3. Delete the Battle.net folder
4. Run the setup.exe as admin by right clicking on it and selecting "Run as admin".

Let me know what happens
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
Reply Quote
90 Worgen Druid
10355
Dear Blizz person,

I have done ALL of that, (running Vista SP2) And NOTHING.

Have been trying to do this since 8 this morning (EST) would actually appreciate answers instead of the same old droll bs that is given when you dont' know what is wrong with your programs.
Reply Quote
Just to reply an update. I was about to do the same thing you just linked, but when I clicked on the installer, I made a new folder in the C drive titled Diablo III, I made the file myself without clicking the default location. It actually started putting files into it and now I'm at 13%. Not sure if the folder just wasn't creating itself or what was wrong, but I made the folder manually and it all is working fine, at 45% as we speak.
Reply Quote
85 Worgen Death Knight
1455
I had an issue when doing setup as well. The intial installer hadn't shown any progress, when in reality it was installing everything in the background. Once you see the actual Diablo icon pop up on your desktop, you can try closing the initial installer and opening the updater installer and seeing if it starts showing you progressing, it worked for me (I thought my hubby screwed up my downloading progress by closing the first installer, he actually found me a fix, lol).
Reply Quote
When you say delete the battnet folder do you mean the one thats inside the diablo III folder which holds battlen.net.dll ?? that's the only file in there. mine was stuck at 77% i then restarted several times task managered agent.exe and everytime since the first it's hung up at 25% now with 35.2 mb remaining, connection info shows "No download available"

Well f me, I added a Diablo III folder to reg program files there wasn't one there, there was one however already in my program files (x86), after doing that and relaunching it has progressed now however this new magic Diablo III (program files) folder remains empty

And it appears to have hung up again at 78%
Reply Quote
When you say delete the battnet folder do you mean the one thats inside the diablo III folder which holds battlen.net.dll ?? that's the only file in there. mine was stuck at 77% i then restarted several times task managered agent.exe and everytime since the first it's hung up at 25% now with 35.2 mb remaining, connection info shows "No download available"

Well f me, I added a Diablo III folder to reg program files there wasn't one there, there was one however already in my program files (x86), after doing that and relaunching it has progressed now however this new magic Diablo III (program files) folder remains empty

And it appears to have hung up again at 78%


No... re-read what he post again. There is a Battlenet folder under Program Data Folder.
Reply Quote
still stuck at 0%
Reply Quote
Ok folks lol, so my previous post changed direction 3 times within 5 minutes, it has successfully installed now. The only thing I would say is if you see a download happening leave it alone, while it might not appear to be progressing I'm pretty sure it is. However if you do not have a download, and go into connection info and it says "no download available" or something along those lines, open task manager and kill agent.exe then relaunch the original file you started installing with, not the new d3 icon that showed on the desktop.

Of course first wait for a blizz response but if in an hour no ones come by and its still going I'd kill the process and try again.
Reply Quote
When you say delete the battnet folder do you mean the one thats inside the diablo III folder which holds battlen.net.dll ?? that's the only file in there. mine was stuck at 77% i then restarted several times task managered agent.exe and everytime since the first it's hung up at 25% now with 35.2 mb remaining, connection info shows "No download available"

Well f me, I added a Diablo III folder to reg program files there wasn't one there, there was one however already in my program files (x86), after doing that and relaunching it has progressed now however this new magic Diablo III (program files) folder remains empty

And it appears to have hung up again at 78%


No... re-read what he post again. There is a Battlenet folder under Program Data Folder.


Whoops, probably shouldn't have left that part out. There wasn't one and still isn't one for me, not in either program files folders and I am showing hidden. Just a Diablo III in x86 as I said(with a bnet folder located inside)
Reply Quote
85 Human Death Knight
7400
cause its not in your Program files its in program DATA
Reply Quote
90 Draenei Shaman
16805
I am having the same issue, have deleted all battle.net folders, gone through with a fine tooth comb. Keep getting "You need a new OS" and then nothing for installation. I guess I need Windows 8?! -.-
Reply Quote
85 Blood Elf Mage
1665
I do believe the solution to this problem is to just keep the Installer running, regardless of what % it tells you it is at.

I'm watching my Diablo 3 folder in Program Files becoming larger and larger, even though i'm at 0%. I'm up to 8 gigs now. It's definitely installing something, even if the progress bar says it isn't.
Reply Quote
so much trouble ... why not make it as simple as wow installer...
Reply Quote
05/14/2012 03:20 PMPosted by Azenin
cause its not in your Program files its in program DATA


fml - well here's the good news, it installed without me having to delete that folder since I'm too excited(retarted) to read properly
Reply Quote
85 Tauren Paladin
9285
I do believe the solution to this problem is to just keep the Installer running, regardless of what % it tells you it is at.

I'm watching my Diablo 3 folder in Program Files becoming larger and larger, even though i'm at 0%. I'm up to 8 gigs now. It's definitely installing something, even if the progress bar says it isn't.


I'm watching the same thing happen right now, not sure how to tell when it's done, but it does seem to be installing. My installer still says 0% too.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]