Diablo® III

Unable to Launch game

I run the update and everything is fine (patches to 100%) but when I hit play, it just says "Launching" and nothing actually launches :/ Anyone getting this issue ?
Reply Quote
Try to kill the process and restart launcher. I did just that and it works.
Reply Quote
I've tried that. I know I had that issue in the beta and it would sometimes work but it doesn't work this time around
Reply Quote
After I kill the process and restart the launcher, it re-downloads and applies the patch like it's never done it but it still won't launch the game
Reply Quote
I am giving up. The game just doesn't launch.. big disappointment. I really don't want to re-download considering the size of the game. Oh well
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]