Diablo® III

Really Weird Problem Please Help

The first time I downloaded D3 several days ago it worked fine and when I updated it today that went smoothly too. However when it launched an error would occur. I would be prompted with the option to try to find solution to the problem or close program. I then uninstalled the game and during the reinstalling I clicked play at 26% to see if it would launch. This caused the launcher to not update and remain stuck at 0%. I then made a new user and tried to download it and after downloading the launcher my game was up to date and playable. The logsin screen comes up, too. Any thoughs? thanks
Edited by Murairy#1808 on 5/14/2012 6:34 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]