Diablo® III

Press Play, Game does not launch

90 Tauren Paladin
6410
Posts: 19
Game is up to date. No errors. After clicking the play button the Diablo 3 Banner shows on my screen for a few seconds then goes away. nothing happens after that. game wont launch.

win 7 ultimate.
nvidia gtx550 Ti graphix card.
Reply Quote
Posts: 53
bump
Reply Quote
90 Blood Elf Paladin
16005
Posts: 26
i don't even get a banner. i hit play, the launcher goes away and nothing.
Reply Quote
bump - same - i posted my specs and no response
Reply Quote
90 Tauren Paladin
6410
Posts: 19
CLosing the diablo.exe and the agent then restarting Does not work. Tried running in different compatibility modes with no difference.
Reply Quote
keep this one going until we get a blue post...
Reply Quote
90 Blood Elf Paladin
16005
Posts: 26
my husband who was too lazy to download himself copied my d3 folder to his computer, his launcher still had to update, but he hits play and it launches no problem. how is that possible if he took it from me and mine doesn't launch?
Reply Quote
Posts: 3
Same Issue Here
Reply Quote
61 Tauren Paladin
490
Posts: 18
bump happened to me on 3 comupters. blue post please.
Reply Quote
90 Orc Rogue
11255
Posts: 94
You all realize the game will not be available to play until midnight, PST, right?
Reply Quote
Posts: 16
we do, but you can view the movie and the log in screen if it loads up properly; for us, it just does nothing when we press 'play' on the launcher
Reply Quote
90 Blood Elf Paladin
16005
Posts: 26
05/14/2012 07:24 PMPosted by Zadgrub
You all realize the game will not be available to play until midnight, PST, right?


we realize it won't be playable, but we should be able to get to the login screen even if we can't log in yet. my husband can, i can't.
Reply Quote
well i had same problem, but my firewall was off. Just add Diablo 3 to safe app and try run launcher again.
Reply Quote
bump for great justice to this problem
Reply Quote
85 Night Elf Priest
9920
Posts: 7,046
I blame that stupid Agent.exe

I swear during the beta, anytime i wanted to launch the game I had to force quit Agent.exe in processes, because it never goes off on it's own and for some reason it would break the game trying to launch.

I made it work today by going into windows xp sp3 compatibility mode, but now that's not working anymore.

I also try force quitting Agent.exe and trying to launch again and that's not working anymore either.

IDK what they were thinking when they implemented this Agent.exe crap because it is a nightmare at BEST.
Reply Quote
15 Undead Warlock
30
Posts: 49
bump
Reply Quote
90 Tauren Paladin
6410
Posts: 19
added the launcher and .exe to firewall exempt list.... still no joy.. COME ON BLUE POST!!!
Reply Quote
90 Blood Elf Paladin
7665
Posts: 52
same here, was installing d3 for my sister on her pc and it went into the login screen... after i quit, tried to go back, im stuck at launching..
Reply Quote
90 Blood Elf Paladin
16005
Posts: 26
i've even tried replacing my folder with his now. didn't think it would work since he got it from me originally, but i'm baffled now. he gets to the login screen no problem every time after copying the folder from me. but i can't even get the banner after hitting play. still getting nowhere here.
Reply Quote
Posts: 16
bump
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]