Diablo® III

Press Play, Game does not launch

i got s similler problem i go press the launcher then message pops out with a new patch i pressed ok then the diablo iii laucher comes up again and the same thing happens over and over again for the past 24hours PLEASE HELP!!!
Reply Quote
i had the similiar problem.

Now it is downloading something.
Reply Quote
guys loading the launcher until its says play now and closing the agent.exe, BEFORE hitting play now has been working for me. Hope it helps.
Reply Quote
I run diablo and it says initializing and the PLAY button is grey i cant press play.
HELP HELP PLEASE....
Reply Quote
I got problem I run diablo3.exe it checking for udates .... for eternity then it gives message it cannot connect to server ...>.> last night all was working as it should lul :|
Reply Quote
FIXED
CHANGE YOUR DNS TO:
156.154.70.1
156.154.71.1
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]