Diablo® III

Tried everything, please help - Agent

90 Orc Warrior
7360
Posts: 99
I have read and tried every single fix listed on this support forum. I am currently running Vista, and I have gone through literally everything. The only progress I can make is the first time I delete the battle.net hidden folders it will get to updating system files and get stuck about 1/3 through. I have task manager running and there are 3 copies of Agent that pop up. I feel like this is part of the problem. I get the same error message that is being displayed on here every time. None of the troubleshooting idea the error message suggest do anything.

Aside from the fact that this is probably one of the worst times I have ever had installing a game, it is making me strongly regret paying for this game. This is ridiculous that this is allowed to happen, and it is becoming an enormous waste of time to try and fix things everywhere to use a product that I have purchased with the intention of using.
Reply Quote
Man, i have exactly the same problem. And it seems that quite a lot of other people have the same problem too.

Although i think it has nothing to do with 3 processes of Agent running. I have only one at the same time, which crashes again and again around 1/3 through as you say.

About time blizzard provides some fix to this.
Reply Quote
Posts: 3
I've got exactly the same problem also, desperate for an answer on how to fix this
Reply Quote
Posts: 8
Same problem - 3 versions of agent, 1/3 through, vista, tried every official and unofficial fix.
GG agent.
Reply Quote
Same problem...Vista 32bit

Tried everything listed on forums. Very frustrated and annoyed...especially from Blizzard.

I only get one agent.exe on task mnger though.
Reply Quote
give it up...the only response you get is the same fix that has been around for 20 hours - manually ending the agent process...obviously blizzard themselfes have no idea what the problem is...
Reply Quote
85 Human Paladin
4535
Posts: 61
we're going to have to wait till Blizzard comes back and finally address that there is still a problem, which should be in a couple hours here. its 3:26am PST. Going to get a couple zzz in before I freak out soon.
Reply Quote
yeah, same issue here. when you look at the log in the battle.net folder you'll see it keeps looking for the agent, then saying not found and tries to open another one.
Reply Quote
85 Blood Elf Priest
1130
Posts: 348
I have read and tried every single fix listed on this support forum. I am currently running Vista, and I have gone through literally everything. The only progress I can make is the first time I delete the battle.net hidden folders it will get to updating system files and get stuck about 1/3 through. I have task manager running and there are 3 copies of Agent that pop up. I feel like this is part of the problem. I get the same error message that is being displayed on here every time. None of the troubleshooting idea the error message suggest do anything.

Aside from the fact that this is probably one of the worst times I have ever had installing a game, it is making me strongly regret paying for this game. This is ridiculous that this is allowed to happen, and it is becoming an enormous waste of time to try and fix things everywhere to use a product that I have purchased with the intention of using.
Right click and run as Administrator and if it pops up something called "Blizzard setup manager" click yes. It sounds like (Since you're on vista) you're not giving your computer permission (running as admin)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]