Diablo® III

Need some Help -"Below Minimum Specification"

Long story short.

A problem came up just today where my only option was to wipe my computer completely. I go to redownload D3 afterwards and I get the message:

"Below Minimum Specifications"

"Diablo 3 requires a new operating system"

Uhhh, what? I played the beta perfectly fine with zero problems. On top of that, I pre-downloaded Diablo 3 today, before I had to wipe my system.

Any ideas?
Edited by Rawzlekk#1749 on 5/14/2012 10:40 PM PDT
Reply Quote
90 Blood Elf Paladin
6165
Updates
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]