Diablo® III

Install requires new operating system

85 Orc Warrior
0
Hey guys

Apparently Windows 7 64bit OS is not new enough for D3 CE

Managed to fix it by right clicking the install setup file and ticking "run this program in compatibility mode for windows xp service pack 3"

And just to point out, my Windows 7 64bit is fully patched and has SP1

A bit dissapointed that this bug is there on ship
Edited by Drekka#6857 on 5/14/2012 9:21 PM PDT
Reply Quote
90 Human Paladin
10155
Have this bug on vista, not sure how to fix it.
Reply Quote
85 Orc Warrior
0
05/14/2012 09:10 PMPosted by Trôy
Have this bug on vista, not sure how to fix it.


Did you do what I did? That fixed it
Reply Quote
90 Human Paladin
10155
Tried to change the properties to service pack 2, don't have 3 as an option. I'm not very tech savvy unfortunately.
Reply Quote
85 Gnome Mage
1865
Me too!! im vista
Reply Quote
86 Dwarf Hunter
5080
Service pack 3 isn't an option for me on Vista 64. Service Pack 2 is an option, but that doesn't work either.
Reply Quote
You are probably missing Win7 64bit service pack 1. Update to SP1 first, then it should let you install without turning on compatibility mode.

No idea what happened to the Vista guys. I'm going to try to install it on my Vista comp tomorrow. Will see if I run into the same issue.
Reply Quote
sounds like you are not running the latest "service pack" for your OS.

you may need to run windows update to download the latest service packs.
Reply Quote
86 Dwarf Hunter
5080
To be honest, I think this is a Windows 64 problem for Win7 and WinVista. Any ideas on how to run this in 32 from a 64 machine?
Reply Quote
Just to verifty:

Windows 7 is on SP1
VIsta is on SP2
XP is on SP3

You can try to manually get them from:

http://windows.microsoft.com/en-US/windows/downloads/service-packs
Reply Quote
86 Undead Warlock
3415
The latest service back for Vista is 2, I've updated my video drivers, direct x also and nothing, very disappointed.
Reply Quote
85 Orc Warrior
0
You are probably missing Win7 64bit service pack 1. Update to SP1 first, then it should let you install without turning on compatibility mode.

No idea what happened to the Vista guys. I'm going to try to install it on my Vista comp tomorrow. Will see if I run into the same issue.


My windows 7 64bit is fully updated, and has SP1
Edited by Drekka#6857 on 5/14/2012 9:20 PM PDT
Reply Quote
86 Undead Warlock
3415
Oh wow what tool I am, I had it running in compatibility mode from trying to install it last week. Unchecked it and its' working fine now.
Reply Quote
85 Gnome Mage
1865
What do you mean?
Reply Quote
90 Human Paladin
10155
Where do you get the activation code if you got this from the 12 month world of warcraft deal?
Reply Quote
85 Orc Warrior
0
I really hope this mini first day launch patch fixes these technical issues

Ive run into even more issues after this first one, Ive managed to fix it,

:(
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]