Diablo® III

HELP! I cant install

Posts: 6
Hi all, so i bought the digital version, downloaded the Diablo-III-Setup-enUS file and got all excited.

Then I run the file and it gives me the little window saying Updating setup files but after that it just closes and NOTHING HAPPENS! (no error message)

I have read the forums and deleted the

c:/program data/battle.net folder

and still it just goes through the same motions: Updating setup files for a while and then once thats done it exits and nothing happens. I have re-deleted the battle.net folder twice now and still the same thing happens. It's like the blizzard launcher fails to start. I had played the demo but deleted it before attempting this install.

Any ideas??? please help me!
Reply Quote
Posts: 4
Well mostly dito. Mine wont actually get past the updating screen and I already read the forums and made sure the secondary was not set to disabled as well as the above steps with nothing happening or helping the situation
Edited by Phaerun#1683 on 5/15/2012 2:00 PM PDT
Reply Quote
Posts: 110
same problem here :(
Reply Quote
59 Undead Death Knight
9320
Posts: 3,112
Then I run the file and it gives me the little window saying Updating setup files but after that it just closes and NOTHING HAPPENS! (no error message)

Enable Secondary Logon service.

http://us.battle.net/d3/en/forum/topic/4903950606
Edited by e1D#1473 on 5/15/2012 2:01 PM PDT
Reply Quote
Posts: 6
Yup I had ALREADY done the enable Secondary logon service, it was set to manual.

Trying now with the setting to AUTOMATIC

The problem is not that it "hangs" on updating files. I actually think it FINISHES updating the setup files but then when it tries to launch the launcher NOTHING HAPPENS!

I have tried to go to the battle.net folder and launch the launcher manually but i get a

"must be in game folder" error

THIS IS SO FRUSTRATING
Reply Quote
Posts: 4
I followed those steps as well and was still having this issue.

I thought I had previously deleted my battlenet folder but when doing a check for C:/Programdata/Battle.net under a general search I found I had 2 such files. I deleted both the one listed and the one under my blizzard file. When I restarted my McAfee initiated to allowed access two different times and after I checked the always allow button it finally worked.

I am now downloading client. On a side note I also went through the normal steps on my laptop and had no issues with makes me believe it is more likely firewall related issue for me in this situation even though initially I had disabled my firewall.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]