Diablo® III

Screen Turns Black and alt tabs me out.

Bump. This needs to be looked into.
Reply Quote
100 Human Paladin
7205
Posts: 13
Bump. I lowered FPS to 50, and it worked for a time, but it has started up again
Reply Quote
91 Blood Elf Paladin
8600
Posts: 4
I am having the same issue, lowered the FPS to 50 as well and worked for about an hour, but then it started up again.
Reply Quote
I'm having the same problem. Win 7, AMD Radeon HD 6700. All drivers up to date.
Reply Quote
C'mon Blizz, at least any reaction? "We are looking in to it" would be sufficient!
Reply Quote
i have same problem

Every time it happen , my game is freeze like 6~7sec, then black screen 1 sec( like alt +tab)

it makes game unplayable

My GPU is ATI 5670 and my CPU intel E6550
Reply Quote
Posts: 29
i7 920
evga gts 250 latest drivers
6 gb ddr3 1600

Ok so I've made the game playable by using the evga utility to underclock the card back to 770 core 1100 mem. I also disabled the evga utility from booting up on startup. The game runs slower overall but now the drivers don't crash. For the record I'm not sure if the clock settings in EVGA Precision will hold if the utility isn't running. So it may actually be running at some different stock setting.

At first it seems like a overheating issue but I can hear the fan and its no where near max when the drivers crash.

Try this and let me know what is does.
Edited by Hyperlite#1659 on 5/16/2012 7:58 AM PDT
Reply Quote
Ok so I've made the game playable by using the evga utility to underclock the card back to 770 core 1100 mem. I also disabled the evga utility from booting up on startup. The game runs slower overall but now the drivers don't crash. For the record I'm not sure if the clock settings in EVGA Precision will hold if the utility isn't running. So it may actually be running at some different stock setting.

At first it seems like a overheating issue but I can hear the fan and its no where near max when the drivers crash.

Try this and let me know what is does.

This is the only solution that work for me. My card is a oc version of the 9800gtx+ from BFG (stock overclock), if I underclock it to the frequency of a common 9800gtx the problem is gone.
Reply Quote
Posts: 16
I tried that yesterday and it didn't work me. I can't even through a dungeon anymore with out my whole PC freezing up with a sound loop(everything is updated).
Reply Quote
100 Pandaren Warrior
12685
Posts: 420
Yup I get this as well with my GTS 250 superclock..... its been like this since beta, only solution I've been able to find is to underclock my card by 50hz in each section, its not fool-proof, but it allows me about 3-4 hours of play at a time generally without to many problems. Only downside it seems... once I do have a problem it requires a full computer restart and reset of the underclock settings to work again.
Reply Quote
100 Pandaren Warrior
12685
Posts: 420
I've now had to restart my machine 5 times in the last 30 minutes because of this... its getting annoying enough to a point where I may be asking for a game refund soon as this is just plain unplayable right now -.-
Reply Quote
05/15/2012 02:47 AMPosted by ChobitsCrazy
I'm getting this with my GeForce 9800 GTX+ as well


Getting exact same thing with my 9800 GTX+ as well.
Reply Quote
Well i have noticed that the game locks up when the cards fan is at its highest speed. My video card personally is hot as hell (untouchable). I dont want to damage the card, it was very expensive. I really need some input on this, and a fix for the game would be AWESOME!
Reply Quote
100 Human Paladin
18420
Posts: 626
Bumping this for the people that this is affecting. This is certainly a game breaking issue that needs to be addressed, either by Blizzard or Nvidia, or both!
Reply Quote
it seems like not only Nvidia ... but also including AMD VGA card
Reply Quote
86 Worgen Rogue
5190
Posts: 8
Same Problem , black screen blinks, eventually tabs me to desktop and if Im running windowed I can see the message saying the driver stopped working. The sound seems unaffected and the game always resumes after a few seconds.
I have a GTS 250 like most of the posters here.
Reply Quote
Bump, same problem, nvidia GTS250, low res still not working, latest driver.
Come on Blizz, please fix this
Reply Quote
Same issue. 9800GTX+ on intel 4core with 4 gigs of RAM and Win 7.

This was going in the beta too... i've tried older drivers, beta drivers, settings in the game, settings in nVidia control panel... NOTHING HELPS...

So i hope the people i've paid for the game to HELP!!!!!!!!
Reply Quote
Same issue. 9800GTX+ on intel 4core with 4 gigs of RAM and Win 7.

This was going in the beta too... i've tried older drivers, beta drivers, settings in the game, settings in nVidia control panel... NOTHING HELPS...

So i hope the people i've paid for the game to HELP!!!!!!!!


Here is my thread. Same card, same amount of ram and same OS.

http://us.battle.net/d3/en/forum/topic/5134263474
Reply Quote
BUMP!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]