Diablo® III

Screen Turns Black and alt tabs me out.

Posts: 93
bump once more
Reply Quote
Posts: 1
I had to cap my FPS at 40 in order to fix this issue. No crashes for the last 3 hours! My vid card is a 9800M GS.
Reply Quote
bump - same issue here with a 9800gtx
Reply Quote
Lowered the clock of my GPU and things seemed to be going well.

Then I lost my network connection... over... and over.. and over...

Just can't f***ing WIN with you Blizzard! WTF?! Now I can't even play the damned game long enough to see if the workaround even WORKED.
Reply Quote
05/16/2012 11:13 PMPosted by peekayMRH
bump - same issue here with a 9800gtx


I have the 9800gtx+ and a G15 keyboard. I downloaded EVGA Precision http://www.evga.com/precision/ to monitor my gpu performance during the game play on the monitor that is on my keyboard. It is running at 81 degree c. and my fan runs at about 70% speed in full screen mode. Also left the FPS at 150. The game would tab out constantly. So then the only thing I did was switch to full screen window mode and reduced the fps down to 110, and changed my gpu clock from 775 down to about 750 and bam. Issue fixed. EVGA Precision is also cool because you can overclock your gpu with it. You should try it out.

I would also like to mention that my cpu is an Intel Core 2-quad Q6600 overclocked and Ihave 8 gb ram.
Edited by Arrancar#1154 on 5/17/2012 12:05 AM PDT
Reply Quote
Tried fullscreen windowed mode - still no success. Time between hiccups increases as you lower the fps, but that just makes the game unacceptably ugly.
Reply Quote
85 Blood Elf Rogue
1480
Posts: 35
I've posted a fix for this for people who use Geforce cards.

http://us.battle.net/d3/en/forum/topic/5150106459?page=1
Reply Quote
85 Blood Elf Rogue
1480
Posts: 35
It seems most video cards in thier factory settings are overclocked. If you turn the 3 clock speeds down by 100 - 200 Mhz it may fix it. It's worked wonders for me.

I turned my core speed down 100 Mhz and the 2 others down by 200 each. To be specific. Refer to my thread posting for specs / versions.
Reply Quote
Try clicking vertical synch under options. That was the only thing I did as I was getting this problem every 10-15 minutes. It still happened once or twice within a 6 hour span, but at least I wasn't getting alt tab out at all, and it just lagged for 1 second or so, as opposed to 5 seconds, or getting alt-tabbed out. I play on high resolution,ect for a GTX 260 overclocked on a I7 920 with 6 gb of ram. No hiccups as except for the two times I mentioned. I did reset my 3d options to default through the Nvidia Control Panel just for the heck of it. Give it a try.
Reply Quote
Just to clarify, you probably aren't getting alt-tabbed out as you can't run any commands on your desktop. This seems like a synch issue. You can still run commands,ect, and will reflect in your game when it reverts back. Which means the game is still running, just that on your screen it is not showing it. Nvidia and Blizzard need to figure this out.
Edited by Mushuchalaka#1328 on 5/17/2012 1:02 AM PDT
Reply Quote
GTS250 / win7 64bit as well here

argh just acknowledge this Blizz.. I'm willing to wait a couple of days if I KNOW you're at least looking into it, game is so frustrating to play like that! :(
Reply Quote
For anyone with amd problems i fixed my problem by uninstalling the catalyst control center completly following
http://www.youtube.com/watch?v=ihVEGWrk5E4&list=UUqMGPTWq2Mbo9ywGGmleWiA&index=6&feature=plcp and only having the device driver installed, so far 3 hours with no prbs and randomly fixed my see through horse in skyrim ^^
Reply Quote
Problem fixed !, I turned up my fans to 100 % and lowerd my Ati overdrive by like 200-300 mhz. I worked for me and im useing Ati raedeon 5800 series video card
Reply Quote
I "downclocked" my radeon hd 5770 by 100 on everything i could using catalyst and i could run the game without the problems, which I'd get every 5 seconds prior to that. Also using default in-game video settings. I'll let you guys know if it really works when i get back from work to test on a longer period. Looks promising though.
Reply Quote
Posts: 13
bump. Get on this.
Reply Quote
100 Pandaren Warrior
12685
Posts: 412
I capped my FPS to 70 normal and 8 background, resolution to 1280X720 (my natural is 1900X1080) and downclock all my GC clocks by 50hz on my GTS250 in order to get D3 to stabilize, worked like a charm for half of yesterday.... sucks that I have to play a more pixilated version in lower rez but at least its not crashing now..... now just to wait on a proper fix for the main problem so i can view the game as i was ment to.
Reply Quote
90 Gnome Warrior
11585
Posts: 33
Bump for justice

GTS 250, Beta was fine, etc, etc. same as everybody.
Reply Quote
85 Worgen Warrior
4200
Posts: 15
Im Having simular issues, post on my thread is this is what your experiencing, Waiting on a Sticky and any possible fixes

http://us.battle.net/d3/en/forum/topic/5150106766
Reply Quote
Posts: 13
I've had the GTS 250 problem all along too. Get Nvidia System Tools, go into it in your control panel and under the GPU tab, drop all the values by 100MHz and it will work proper with no loss in quality.
Reply Quote
85 Worgen Warrior
4200
Posts: 15
trying the underclock fix and see if it works for me or not

Nvidia Toolset
http://www.nvidia.com/object/nvidia-system-tools-6.08-driver.html
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]