Diablo® III

Screen Turns Black and alt tabs me out.

I had the same issue and underclocking seems to have worked. I played 45 minutes and had no crashes. Can't say it's fixed, but definitely helped.

GTS 250
Win7 64bit

I dropped the sliders around 30% (not sure exact numbers and i forget which program i used)
Reply Quote
85 Worgen Warrior
4200
Posts: 15
it worked
Reply Quote
90 Orc Warlock
13695
Posts: 687
Same i have a single gts 250,.
Reply Quote
My GPU doesn't get near overheat, so unless the driver "thinks" it is for some reason I doubt it is that. I will try underclocking when I get home, although I only consider that a temp fix until Blizzard finds the culprit causing the issue.
Reply Quote
I tried all the "fixes" and none worked for me until now. I finally "resolved" the issue. Here is what I did: I brought the piece of garbage back to the store and got my money back. I haven't had a crash since. It is not the best solution but it is the best one I have been able to find so far. Hopefully they will fix the issue in the future and I will buy it again or I may just get the PS3 version.

One last thing that may help. I just saw that Diablo 3 uses the Havok engine. The other game that I had the same problem with (Just Cause 2) also used the Havok engine.
Reply Quote
90 Gnome Warrior
11585
Posts: 39
Guy from another topic:

"FOR GUYS NEED SOLUTION ON DIABLO 3 WITH NVIDIA GTS 250 TRY
MAX FOREGROUND FPS SET TO 30 - 40
MAX BACKGROUND FPS SET TO 10
STABLE PLAYING AS FOR ME."

Win7 64bits
GTS 250
Fan at 90% manual

Worked so far. endend a whole chaper without seeing the crash again. Although i like Strayke's "fix" lol.
Reply Quote
yea underclocking and lowering frame rate has stopped it for me - doesnt look/run that great but definitely playable
Reply Quote
Guy from another topic:

"FOR GUYS NEED SOLUTION ON DIABLO 3 WITH NVIDIA GTS 250 TRY
MAX FOREGROUND FPS SET TO 30 - 40
MAX BACKGROUND FPS SET TO 10
STABLE PLAYING AS FOR ME."

Win7 64bits
GTS 250
Fan at 90% manual

Worked so far. endend a whole chaper without seeing the crash again. Although i like Strayke's "fix" lol.


This method work on my laptop yesterday. My desktop nothing has worked so far.
Reply Quote
100 Pandaren Warrior
12685
Posts: 430
I've written up a solution for anyone with a GTS250 thats having this issue, i've been playing all day today without problems.

http://us.battle.net/d3/en/forum/topic/5151716903#2
Reply Quote
Got a reply to my ticket finally. They ARE working on this and have already responded on the EU forums regarding our issues.
Reply Quote
Posts: 13
Don't bother changing the framrate.......just underclock and it will run fine.
Reply Quote
60 Tauren Druid
0
Posts: 527
05/15/2012 02:02 AMPosted by Rytchan
Every 30 seconds or so my screen will flicker black


LOL
Reply Quote
85 Human Rogue
0
Posts: 30
Underclocking worked for me on the GTS 250. I was then able to go back to the max resolution and am playing it fine.

I also changed my fan speed to stay at 100%.

Just played for 2 hours without a problem, also in a group still no lag. I did leave my FPS Capped at 70, figure I'll leave everything alone until a patch resolves this issue.
Reply Quote
I turned on Vertical Sync in the game options and that fixed it.

Running a single GTS 250.
Reply Quote
Guys underclocking each of my GTS 250's cores by 50 mhz each, and increasing the fan speed to 80% has worked for me. I was using the Nvidia system tools downloaded from the Nvidia website.

Weird thing is the game seems to run more smoothly now that its underclocked, go figure....

Played for 2.5 hours, no issues...
Reply Quote
Posts: 19
at what did u put it??
Reply Quote
Posts: 19
same here anyone have a solution yet??
Reply Quote
Posts: 13
I have GeForce GTS 250 like a lot of people on here. I've been playing for 2 hours and turning my FPS down to 50 as suggested worked for me. It was going nuts last night. My graphics are turned up from then, but with the FPS down it's working fine.
Reply Quote
Posts: 13
Just an update.. didn't flicker at all... had graphics up to the max with the lowered FPS. I couldn't tell a visual difference from 150.
Reply Quote
Might sound dumb but I tried turning all the in game graphic settings to high and setting the fps to 40-50, v-sync on......and havent gotten a blackscreen/freeze yet

i have the geforce 9800gtx
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]